Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using the alpha 2 version of 11.10 and the keyboard options there do not have an option to force a logout.

Can you tell me the keyboard shortcut so i can add it myself?

share|improve this question
    
See askubuntu.com/questions/18641/… –  htorque Jul 16 '11 at 18:36
    
But isn't that topic about bugs? It's possible that the change to gnome 3 changed the shortcut used to kill the xserver or that i have just missed the menu that lets me choose one. Either way, the command that is executed after one presses control-alt-backspace on the current version of Ubuntu should probably work on the next one as well. That's why my question is neither about a bug, nor about an alpha release only. –  Chriskin Jul 17 '11 at 3:33
add comment

5 Answers 5

When I have this problem, I simply Ctrl + Alt + F2 into a terminal, log in, and type

killall -u  [username] gnome-session

This will basically kill all of your processes and log you out. If you want to logout all users at the same time in this manner, then you leave out the -u [username] part.

I guess you could create a new keyboard shortcut that runs this command. The only problem with this that I can forsee is if the freeze-up is because of gnome itself. Then it may not recognize the shortcut.

share|improve this answer
add comment
up vote 5 down vote accepted

It seems that the latest update added an "options" menu on the keyboard preferences-->layouts that lets me activate the "control-alt-delete" shortcut like before. Or it might have always been there and i missed it.

share|improve this answer
add comment

You can open Keyboard shortcuts and create a new shortcut. Run the command killall -u yourusername gnome-session.

share|improve this answer
    
That was what i was looking for until an hour ago that i found out that the shortcut is still there - thanks though :) –  Chriskin Jul 22 '11 at 0:55
add comment

I would imagine this is the same as 11.04 (or possibly it's just that I'm running Gnome 3), but Ctrl+Alt+Del brings up a box allowing me to logout.

share|improve this answer
    
True, but if everything is stuck there is no way for that box to appear. –  Chriskin Jul 12 '11 at 21:11
add comment

You can enable ctrl alt backspace in the keyboard options this kills the x server and will probably work even if ctrl alt delete does not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.