Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought a new usb webcam for my desktop setup of Ubuntu Natty Narwhal. I plugged it in, started up Cheese, and saw my smiling face. But it was green and lined, very poor quality overall. I am skeptical that this is due to a poor quality webcam. :P

I tried it in Skype, Google+, and Gchat, but all of those showed only a black screen. They recognized the webcam as present, but showed no stream from it.

Kamoso showed a black screen as well, and Camorama had even poorer quality than Cheese.

Here are the details for the webcam from lsusb:

Bus 001 Device 005: ID 093a:2460 Pixart Imaging, Inc. Q-TEC WEBCAM 100

Am I missing a driver, or are there settings somewhere I need to tweak?

share|improve this question

Running LD_PRELOAD=/usr/lib/libv4l/ skype should launch Skype with a fix for black webcam. You can also modify the launcher to do it automatically.

Also looking at this, it seems that your webcam isn't properly supported. You should have looked at that page before buying.

share|improve this answer

Ubuntu 12.04
64 bits

For the following camera to work:

Bus 003 Device 002: ID 093a:2460 Pixart Imaging, Inc. Q-TEC WEBCAM 100

I had to:

  1. sudo apt-get install libv4l-0

  2. locate

The locate returned two files, I tried the x64 version, but din't work, so I issued the command to preload that file:

env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ skype

And skype now works well with my camera.

Please note that gstreamer-properties helped me confirm that my camera was working.
And don't forget to add your user to the video group

share|improve this answer

Try these commands

sudo modprobe -r gspca
sudo modprobe -r zc0301
sudo modprobe gspca
share|improve this answer
The response to each is: FATAL: Module [gspca|zc0301] not found. Is that what you wanted? – Sir Emeth Jul 13 '11 at 15:28
Wrong model i guess. – Amith KK Jul 14 '11 at 11:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.