Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I signed up for the Ubuntu One free account. This has worked, and I have a couple of folders, and I added one file into one of those folders. All synced with Ubuntu One OK.

Then, I installed the "Ubuntu One Files" App onto my Android phone. I selected "Auto-upload any new photos" on installing.

After signing in, I could see my folders, and the one file, I selected this and it downloaded to my Android phone. Perfect.

Then I took a photo on my phone. No auto-upload. Hmm, mildly irritating. But I still have the "Share" option, this allows me to Share to Ubuntu One. Fine, I selected that. And it uploaded the photo.

But now, on the Web, I have a new folder, under "My Synced Folders" there's a new folder called "~/Pictures - GT-I5700", this contains my photo.

This has not synchronised to my PC though. My PC folders are under the "Folders" title. It seems there's no way to move this picture from the "synced folder" called "~/Pictures - GT-I5700" into a folder that is synchronised with my PC.

Am I doing something wrong? Because this is not intuitive. My expectation, was to take a photo on my Android phone, and Ubuntu One would make this appear on my PC.

So what do I need to do to make this happen?

Regards

Steve Vaughan

share|improve this question

closed as too localized by fossfreedom May 8 '12 at 20:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
1000 views in one year... closed too localized??? –  Mike Pennington Oct 26 '12 at 1:10
add comment

3 Answers 3

As of 11.04, newly created cloud folders are not automatically synced to your machine (because you might have many machines, and not want the new cloud folder on every one of them). If you open the Ubuntu One control panel on your PC, under Cloud Folders you'll see a list of your cloud folders, and you can then tick any folder you want synced to this PC. From them on, all new photos that appear in that folder from your phone will automatically be synced to the PC.

In 10.04 and 10.10 the folders were automatically synced by default, because the udf_autosubscribe option was set to true. It's possible you have that option set to false for some reason, either in /etc/xdg/ubuntuone/syncdaemon.conf or in ~/.config/ubuntuone/syncdaemon.conf.

share|improve this answer
    
Thanks, but I don't have this option on Ubuntu 10.04. I don't have the "control panel". Is there a config file I can edit by hand? I don't have any issues editing config files. –  user21494 Jul 12 '11 at 16:37
    
sil's answer is correct, but I would add that you can sign in to Ubuntu One in your browser at one.ubuntu.com and then click on 'Files'. You should see your Pictures folder there (in my case it's called 'Pictures - HTC Desire'). Click More, then choose to sync the folder. –  Tom Brossman Jul 12 '11 at 19:57
    
Thanks JE2Tom. But when I click on "More", I get the options "Share Folder" and "Stop syncing this folder". Nothing else. I don't want to "Stop syncing this folder" because then it won't sync with my phone. I want it to sync with my PC as well, but there's no option for this. I don't want to upgrade to Ubuntu 11.04 just so I can tick a box - there must be another way to do this. –  user21494 Jul 13 '11 at 10:00
    
In /etc/xdg/ubuntuone/syncdaemon.conf, udf_autosubscribe.default = True, and the option is not there in ~/.config/ubuntuone/syncdaemon.conf –  user21494 Jul 13 '11 at 10:05
add comment

OK gentlemen, thanks for your efforts but all is now working as it should.

I tried running the u1sdtool by hand, and it was reporting a python import error: (ImportError: cannot import name TypedConfigParser).

To cut a long story short, I ended up reinstalling python-configglue, and all of Ubuntu One. When I fired everything up on my PC, my "Pictures - GT-I5700" folder was downloaded straight away, along with another file I'd uploaded from my phone. The end result is, it all works.

So possibly my problems were caused by some squiffy Python. Again - thanks for your help.

share|improve this answer
add comment

Had the same issue but another solution: The folder was actually synced, but not inside my Ubuntu One folder on my PC. It is located in my home directory.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.