Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a Spyder 2 colorimeter that I'm trying to get to work under Natty (11.04). I'm following the instructions that are outlined here and the output I'm getting in the terminal is:

Setting up the instrument

I've used this same device with success on Windows and on Ubuntu 10.04. I've tried using dispcalGUI which is a wrapper around the ArgyllCMS tools, and I get the same results.

How would I go about determining what is going wrong? I'm already running dispcal with the verbose flag and it's not being very verbose(!)


Here's some additional information about what I've tried so far and common solutions listed in the ArgyllCMS and dispcalGUI FAQ respectively.

  1. Installed the driver using spyd2en and it works successfully.
  2. Done sudo chmod 777 /dev/bus/usb/002/006 to make the device read/write/executable by everybody. I understand the device entry changes, and I determined the correct entry using lsusb.
  3. Run dispcalGUI as root.

This is the output of lsusb.

Bus 002 Device 006: ID 085c:0200 ColorVision, Inc. Monitor Spyder
Bus 002 Device 005: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0402:9665 ALi Corp. 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
share|improve this question
up vote 0 down vote accepted

Seeing as nobody has answered this, I thought I'd share my experiences as I've now managed to get the Spyder 2 colorimeter working.

The easiest solution? Upgrade to Ubuntu 11.10 Oneiric Ocelot.

The combination of the new kernel (3.0) and new version of ArgyllCMS (1.3.3 instead of 1.0.x) has made the Spyder 2 work again on my hardware. You can get fix this in 11.04 by using a 3.0 kernel and using the latest version of ArgyllCMS which you have to compile yourself, but it's just so much easier to install Oneiric.

I don't know what changed in the Linux kernel or ArgyllCMS, but I'm glad to report that this has now been fixed and my photos now look beautiful on my monitor :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.