Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I keep hitting it accidentally and it really annoys there any way to disable it's default behavior?

share|improve this question
What is the default behaviour, apart from toggling insert/overwrite mode in editors? – enzotib Jul 11 '11 at 16:37
That's the default behavior. I want it to do nothing. – Jorge Jul 11 '11 at 19:20

3 Answers 3

up vote 5 down vote accepted

Go to Keyboard Shortcuts in System settings, then press Add button and insert a Name of your choice, say "DisableIns", and true as a hermless command then press Apply button.

Now, in the Custom Shortcuts section you will find an entry

DisableIns | Disabled

Click on disabled, then perform your custom shortcut Ins. Press close, you're done.

share|improve this answer

I'm not sure it is the "right" way, but in my tests I could disable the behaviour of Insert using the following command:

$ xmodmap -e "keycode 118 ="

If this works for you, you could put the assignment in a file ~/.Xmodmap, i.e.

keycode 118 =

which should be loaded automatically at login. See questions here and here for more information about local xmodmap configuration.

share|improve this answer

Type sudo nautilus in Terminal. Then go to /usr/share/X11/xkb/symbols and open pc. Then change this line:

key  <INS> {    [  Insert       ]   };


key  <INS> {    [  XF86Send     ]   };// Insert

Then run this:

sudo dpkg-reconfigure xkb-data

in Terminal and restart Ubuntu.

This will replace Insert with Send. You can replace it with any other appropriate key. To see a list of keys run this:

xmodmap -pke

Note: A mistake in editing pc. eg inserting an inappropriate character, may corrupt Ubuntu.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.