Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo ThinkPad Edge E520 (1143CTO) and I'm having problems getting my wireless NIC to work, as far as I can tell the drivers and firmware are all installed and the device is working.

I have searched around and have done all the fixes I can find online, this is my first 'real' experience with Linux, so patience is appreciated, as is any help I can get. I also had this problem with Linux Mint 11.

It appears that the model of my card is BCM43224, but it doesn't show up anywhere in the with any commands?

sudo lshw

 *-network DISABLED
            description: Wireless interface
            product: Broadcom Corporation
            vendor: Broadcom Corporation
            physical id: 0
            bus info: pci@0000:09:00.0
            logical name: eth2
            version: 01
            serial: ac:81:12:3e:1d:ca
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=wl0 driverversion=5.100.82.38 latency=0 multicast=yes wireless=IEEE 802.11abgn
            resources: irq:19 memory:e1d00000-e1d03fff

sudo lspci

09:00.0 Network controller: Broadcom Corporation Device 0576 (rev 01)

I have tried the Broadcom STA drivers and have also tried the command:

sudo apt-get install b43-fwcutter firmware-b43-installer

sudo rfkill list

0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no

Yet, sudo lshw still shows it as disabled!

Nothing I can find just seems to work. Any help at all is appreciated and I will try any suggestions as-long as you can provide me with the command :)

share|improve this question
    
possible same issue askubuntu.com/questions/33855/… –  freebird Jul 11 '11 at 3:25

1 Answer 1

Here is what I have done but it requires to do it everytime you reboot the system.... -Go to controlPanel==>Hardware==>additional Driver. -select the Broadcom STA Wireless driver and REMOVE it. -Once it is removed, re-ACTIVATE it.. open a terminal. -sudo ifconfig eth1 up

the Wireless should appear again... The only problem is that the next time the system reboot, the driver seems to load, but is not used.. so you have to remove it and reinstall as mentioned above

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.