Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unity worked perfectly in my laptop before. However, today when I hard rebooted my laptop, there's something like disk/drive error detect before the login screen. I waited until the disk/drive check finished and then login. Now there's a pop up saying: "It seems that you do not have the hardware required to run Unity. Please choose Ubuntu Classic at the login screen ...", then Unity did not work anymore. It turned back to Ubuntu Classic automatically, and I could not use any effect.

Any idea about what happened? How can I get it back? It happened the same before, and it turned into worse after that and I have to re-install Ubuntu. That's why I'm so desperate. Please help.

lspci | grep VGA returns:

Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller.

share|improve this question

closed as too localized by fossfreedom Feb 24 '12 at 9:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you try this and then edit your question with the results? askubuntu.com/questions/37651/how-can-i-activate-unity –  Jorge Castro Jul 10 '11 at 21:53
    
It doesn't have any NVIDIA driver in the driver list. lspci | grep VGA returns: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller. Hope it helps. –  Rocky Nguyen Jul 11 '11 at 2:10
    
That graphics system might not have the capabilities to run Unity... Intel Mobile graphics are not powerful enough in most cases to run the 3D Unity –  Thomas W. Jul 11 '11 at 13:38
    
So why it worked perfectly before? I did not face any issues until this thing happened. –  Rocky Nguyen Jul 11 '11 at 14:02

1 Answer 1

Problem fixed: http://ubuntuforums.org/showthread.php?t=1779234&page=2 For some reasons, my ubuntu installed nvidia by itself. Unity works after I removed nvidia. Thanks for your help guys.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.