Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a DELL inspiron 1525 with was shipped with Ubuntu 8.04. It was working ok.

I've decided to move to Ubuntu 10.04 last week. The install process was ok. Unfortunately, after the upgrade, my web access became very unstable. I can see web pages in firefox but it is very slow and I have a lot of errors.

I've checked the network and firefox settings all seems ok.

Does anybody know this problem? How can I investigate further?

share

locked by Marco Ceppi Oct 11 '10 at 14:42

    
This suggests a driver problem in the newer kernel. Are you using wireless to connect to the internet? –  Riccardo Murri Oct 6 '10 at 9:49
    
did you do a fresh install of ubuntu 10.04 or upgrade using the update-manager ? Also, can you check if you face the problem also when you use the livecd/liveusb ? –  koushik Oct 6 '10 at 9:53
    
I've done an upgrade from the CD. I'll test with a live CD. I didn't succeed to make the wireless working yet –  luc Oct 6 '10 at 9:58
    
What do you mean with "have lots of errors"?. Where are those errors?. –  Javier Rivera Oct 6 '10 at 10:52
    
"have a lots of errors" --> Quite often, firefox can not load the web pages. The eth0 network interface seems ok. ifconfig doesn't show any error. –  luc Oct 6 '10 at 11:21
show 4 more comments

4 Answers 4

Is you connection slow only on firefox while browsing? Reason might be ipv6 lookup's witch first needs to fail before it trys to find ipv4 ones.

If that is case type about:config in firefox browser bar and set network.dns.disableIPv6 to true. And restart browser.

share
    
Unfortunately, it didn't fix the pb. Anyway, Thanks very much for this proposal –  luc Oct 11 '10 at 7:04
add comment

This might solve your problem "Fix the Firefox Slow Problem in Ubuntu 10.04" http://crenk.com/fix-the-firefox-slow-problem-in-ubuntu-10-04/

I'm not sure why this bug in 10.04 even exists, but there you have it.

share
    
Unfortunately, it didn't fix the pb. Thanks for your proposal. –  luc Oct 11 '10 at 7:21
add comment

Not a real answer to the question. But I've installed Ubuntu 10.10 on this machine today and the problem disappear.

Thanks all for your help

share
add comment

It sounds like your machine has both ipv6 and ipv4 enabled and only uses the latter when the former fails, which is always in common cases. Try disabling ipv6.

share
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.