Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have here an Asus Eee pc, model is the 1005peb version. Now for the most part it runs fairly decent and quick, not much issue with it except one major one.

Every time I restart or turn on the netbook my brightness is set to full yet my screen is like almost full on black, like it's turned off. I turn down the brightness a couple times using the Fn + F5/F6 keys and it goes nice and bright etc. When I turn the netbook on I have to turn down my brightness level to see the screen at what (I think) is full brightness and it's then ok. If I turn it off and restart etc I have to do it all over again.

Down is up kinda thing...it's an odd and annoying issue, one that I cannot find an answer for anywhere. So if anyone has a solid way of getting it fixed I would be most appreciative. Thanks!

  • I'm using Ubuntu 11.04, Desktop Edition, Standard Grub settings and Kernel no changes to any of the hardcore system settings...

  • I tried Ilari Kajaste's suggestion and it had no effect. Neither better nor worse.

  • @fossfreedom I'll look deeper into your suggestion but at this time it looks almost the same as the second answer so I doubt it is what I currently seek.

share|improve this question
    
Has your question been solved? I could reassign the bounty here if you want, since I got the bounty even though my solution did not fix your issue. –  Ilari Kajaste Jul 23 '11 at 9:13
    
Nope it hasn't it just awarded it to someone.... –  zkriesse Jul 23 '11 at 16:18
    
@zkriesse - did you check your BIOS version and jupiter package as per my answer? Finally enough I had a similar issue with my Toshiba running Lucid. In the end I installed a newer kernel (2.6.37 vs 2.6.32) and this fixed it for me. –  fossfreedom Jul 24 '11 at 20:52

5 Answers 5

Some BIOS's are buggy - for example, this bug-report mentions that a recent BIOS revision fixed brightness issues (revision 1202). Suggest check the vendor website and install the latest available BIOS revision.

Even with a BIOS update, it is worth checking whether the standard eepc grub options still apply to your model

Try adding either acpi_osi=Linux source or

acpi_osi=Linux acpi_backlight=vendor source

i.e.

gksu gedit /etc/default/grub

add to the values above to GRUB_CMDLINE_LINUX_DEFAULT

save

sudo update-grub

What you have described may point to general power-management issues.

Have you installed the jupiter_0.0.50.2_all.deb package on sourceforge? More information about this can be found on WebUp8.

share|improve this answer
    
In my 1005PE the upgrade to bios 1202 fixed the problem, no need of any kernel parameters. –  Rmano Mar 31 at 19:25

I had the same problem with my Asus Eee PC 1001PX. The solution was to add acpi_osi=Linux to the computer bootup kernel options.

The bootup kernel options are controlled by the GRUB boot loader. You need to edit the grub settings at /etc/default/grub to have the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux splash"

After editing the file, you need to make sure you run update-grub for your edit to take effect.

Hopefully this same solution works for you. If it doesn't, you can also try adding the option acpi_backlight=vendor to the same line which was also suggested to me when I tried to get the issue fixed.

share|improve this answer
    
Thanks but this didn't fix my issue. I found this the other day and gave it a shot but no go. –  zkriesse Jul 15 '11 at 23:11
1  
@zkriesse Ok. Well, hope you'll find the solution! I'll leave my answer here anyway, in case it'll help someone else with a similar issue. –  Ilari Kajaste Jul 16 '11 at 13:19
    
That'd be great man thanks :) –  zkriesse Jul 16 '11 at 17:53

What do your settings tell you in /etc/laptop-mode/conf.d/lcd-brightness.conf

The lcd-brightness module allows you to control the brightness of your LCD screen.

   CONTROL_BRIGHTNESS
             When this option is enabled, laptop mode will adjust your LCD
             screen’s brightness settings, if possible. You must configure
             the following settings for this to work.

   BATT_BRIGHTNESS_COMMAND

   LM_AC_BRIGHTNESS_COMMAND

   NOLM_AC_BRIGHTNESS_COMMAND

   BRIGHTNESS_OUTPUT
             The  BRIGHTNESS_COMMAND settings specify commands that should
             be executed in order to set the brightness of your  LCD.  The
             BRIGHTNESS_OUTPUT  setting  specifies where the output of the
             command  will  be  written.  For  instance,  if  your   LCD’s
             brightness is adjusted by writing a numeric value 3 to a file
             called /proc/brightness, you should set the command to  "echo
             3"  and  the output file to "/proc/brightness". If your LCD’s
             brightness is adjusted using a utility  like  "toshset",  you
             should  include  the  entire  toshset  command  line  as  the
             command, and set the output file to "/dev/null".
share|improve this answer

Update for 13.10, kernel 3.11.0-19-generic, 32bit.

I have a 1005PE:

    Manufacturer: ASUSTeK Computer INC.
    Product Name: 1005PE
    Wake-up Type: Power Switch
    SKU Number: 1005PE
    Family: Eee PC

with BIOS:

BIOS Information
    Vendor: American Megatrends Inc.
    Version: 1202 

and it works without any kernel command line parameters

[:~] % cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.11.0-19-generic root=[...] ro persistent quiet splash vt.handoff=7

(I do not know what persistent do --- maybe a remnant of some old test).

I do have a couple of drivers running, but they are doing that automatically --- they are loaded by the kernel without further help:

85% [:~] % lsmod | egrep -i "eee|asus"
eeepc_wmi              12983  0 
asus_wmi               23495  1 eeepc_wmi
sparse_keymap          13708  1 asus_wmi
video                  18777  2 i915,asus_wmi
wmi                    18590  1 asus_wmi

The laptop works ok (although better with xubuntu than the full fledged version); backlight, sound, suspend --- all the hw is working flawlessly.

share|improve this answer

it'a one abnormal behaviour on asus eeepc notebook with Fn brightness keys on ubuntu 14.04. when you press Fn+F5, or Fn+F6 keys to change brightness, brightness jumps almost twice. it's said about, it's a matter of performing brightness change action first by acpi and after that by Xserver, so the result is, brightness changes faster, in larger steps than you like or expect. for me have worked one slighlty different solution, change line at /etc/default/grub as many authors suggest, but insted of acpi_backlight=vendor use acpi_backlight=off use as well acpi_osi=Linux otherwise brightness change will not works totally.

There's no need to install laptop-mode-tools or other packages... but this will cause, brightness change information slider doesn't appear as before (Xserver action is not performed), but brightness changes in normal, BIOS supported steps, it seems to me it's 10 steps at asus eeepc. maybe this can be solution on more problems you've posted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.