Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from Ubuntu 10.10 to 11.04. Everything works well except the workspaces refuse to form more than one row and I'm use to working with a 2x2 grid. The dimensionality of the workspace settings is reflected in the "desktop expo" behaviour obtained from the button in the unity dock, but is not in the Ctrl-Alt- switching. See screenshot:

Sreenshot

Neither the compiz settings (general options) nor indicator-workspaces seem to be able to properly fix this. From reading around, most other people are not having this issue.

Has anyone got some ideas on what has gone wrong and how to fix it?
(n.b. that I'm using Unity 2D)

share|improve this question
add comment

1 Answer 1

There is a workaround:

First of all, install the following package:

sudo apt-get install gnome-panel
  1. Then, launch a terminal and run the command gnome-panel.
  2. Look for the old style workspace icons. By default, it's located at lower right corner.
  3. Right click on it and choose Preferences.
  4. Set the number of rows, in your case, to 2.
  5. Your should get the new workspace changes. Close the window.
share|improve this answer
    
For this to work, you need to install the gnome-panel package and dependencies that include the packages gnome-applets and gnome-session-fallback, but once you've done that, it works fine. +1 –  Simon Mar 1 '12 at 1:03
2  
For future reference this still works in 12.04 for those that need to alter the workspace layout in Unity 2D. –  Maks May 29 '12 at 2:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.