Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Under "Ubuntu One" in my home directory (using 11.04) I have a directory "daily" and under that 7 more directories whose names are the days of the week. A daily cron job gathers a few important files and puts them in the proper subdirectory so that I have backups for the most recent 7 days. Works fine. When I log on to one.ubuntu.com/files, all the directories and most of the files are there, but the files under daily/Wednesday and daily/Thursday are missing.

I've tried waiting. Several days. The wednesday and thursday files that I can see locally does not get uploaded. I've tried disconnecting and reconnecting ubuntu one in the Ubuntu One control panel. Does not help. If I create an empty file under daily/Friday, it gets uploaded within seconds. Doing the same under daily/Wednesday has no effect. I've checked that the file and group owner and protection bits are the same for all files. File sizes are also similar for all directories. The total size of all files is less than 100Mb, so should fit within the 2GB limit.

What more can I try?

share|improve this question
2  
Welcome to askubuntu! I think it will be easier to help you if you provide the scripts you use with cron. That'll enable others to try to reproduce your problem and hopefully they'll find what's causing it. –  N.N. Jul 8 '11 at 21:28
    
I found one thing that worked! moving all the files out of ~/Ubuntu One, so only the "Shared With Me" link remained, and then moving everything back again. Now all the files got uploaded. Weird. –  Joakim Rosqvist Jul 9 '11 at 8:26
    
You should add your solution as an answer and accept it if no other answer is better. –  N.N. Jul 9 '11 at 8:30

1 Answer 1

up vote 1 down vote accepted

Moving all the files out of ~/Ubuntu One and then back again helped - the files that were not uploaded after a disconnect/reconnect were now uploaded.

As for why it didn't work before, I can only speculate - some of the files were previously owned by root and were perhaps skipped by the ubuntu-one daemon because of that. The directory monitoring perhaps only notices file delete/create but not change of ownership.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.