Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The other day I was installing some stuff via software center, when suddenly nautilus becomes unresponsive to the point where it just hangs until I restart.

Now whenever I boot, Nautilus will work fine for 10 seconds then become unresponsive. I checked dmesg and it's filled with this:

[  385.392295] Valid eCryptfs headers not found in file header region or xattr region
[  385.392304] Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO

I found a few bug reports, with no solution. I'm not even sure if that's causing it but seems to be the issue. Wouldn't be so bad if Ubuntu One worked, but it refuses to sync now.

Any ideas?

  • I setup encryption on this drive during install.
  • I should mention if I do gksudo nautilus . in the command line it works fine
share|improve this question

closed as too localized by jrg, Marco Ceppi Dec 31 '11 at 23:48

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you use encryption on your drive when you installed Ubuntu? –  Thomas W. Jul 8 '11 at 18:52
    
Yes, let me amend the post. –  Shazzner Jul 8 '11 at 18:55
    
Do you use Wifi? What kind of Wifi card is in your computer? Many reports indicate that this problem is somehow connected to Wifi setup. –  qbi Jul 20 '11 at 13:47
2  
Perhaps this bug is related: bugs.launchpad.net/ecryptfs/+bug/509180 –  Lekensteyn Aug 13 '11 at 15:12
    
This is likely an ecryptfs issue, unrelated to nautilus. However, since nautilus works with files, issues with the filesystem can cause nautilus to hang. The error message says the encrypted files are corrupted, which could be caused by a bug in ecryptfs, a hardware error (badblocks) or someone tried to manipulate the encrypted files (as root). –  Jan Aug 19 '11 at 18:29

1 Answer 1

It sounds like you created a root-owned file/dir that's not readable by you. You can find the file(s)/dir(s) with the "find" command.

sudo find $HOME \! -user $USER -ls

The "sudo" is in there so that find can traverse root-owned directories. You can (probably) fix them with find, as well:

MYgroup=$( id -g )
sudo find $HOME \! -user $USER -exec chown $USER:$MYgroup {} \;

Note: I should have a single backslash (for shell quoting) before each exclamation or semicolon.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.