Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently purchased and started using a KVM. Most things work as I expect them, but when I switch back to my main [ubuntu 10.04] desktop, numlock gets turned off.

I suspect that it looks to the computer like the keyboard is just plugged in. However, the FunctionLock key doesn't get switched. (The keyboard is a split keyboard with a FunctionLock feature that allows the F1 to F12 keys for other purposes). How can I tell Ubuntu to keep my numlock status? Or, tell it to always switch to numlock is on whenever a new keyboard is plugged in (which is what I suspect the computer thinks is happening when I switch the KVM to it)?

~edit~

At William's suggestion (see below), I installed gconf-editor and looked at the keyboard settings. On the computer that has the behavior I want (numlock on by default), there is a numlock_on setting under /desktop/gnome/peripherals/keyboard/host-desktop1/0/numlock_on (Perhaps important to note, the numlock_on is the only key in the folder, and it doesn't have any of the key documentation set. However, on the other computer (where it is not working), that setting is absent.

According to How do I use the gconf editor?, gconf is used for storing application settings, and not particularly intended for settings stuff.

So, twofold remaining question:

  1. Is that the setting I need? (I suspect the answer is yes, and I'd be happy to test that theory)
  2. How do I set it?
share|improve this question
1  
Not really a solution for your NumLock problem, but the reason why Fn Lock is not affected is that the state/feature of that key is handled inside the keyboard itself, while NumLock is handled in the OS. –  JanC Jan 31 '12 at 20:45
    
@JanC Thanks for the info. –  David Oneill Jan 31 '12 at 21:00
    
OK, if that didn't help, I tried. –  William Feb 3 '12 at 4:19
    
@William: I'm pretty sure the 'numlock_on' you mentioned is what I'm looking for - see my edit to the question. –  David Oneill Feb 3 '12 at 4:25
    
Is there a setting in your BIOS to turn numlock on by default? –  William Feb 3 '12 at 14:25

1 Answer 1

up vote 2 down vote accepted
+50

First suggestion.

Use numlockx: sudo apt-get install numlockx

Second suggestion (just to complete your question)

you can create the key you have indicated using the format:

gconftool-2 --type  bool --set /desktop/gnome/peripherals/keyboard/host-desktop1/0/numlock_on 1

I'm assuming in the example that numlock_on is a boolean value

If numlock_on is a string or int then you'll need to change the type parameter accordingly.

share|improve this answer
    
@Willam: That did not do the trick. However, it did perhaps provide a clue. I'm editing more info into the OP. –  David Oneill Feb 3 '12 at 4:15
    
@fossfreedom Thanks for completing the question. –  William Feb 4 '12 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.