Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've setup my server using the tutorial found here:

Everything is up and running but i can't get my external mail to work... I can send external mail but cannot receive it.

Any help much appreciated.

share|improve this question
Has any of the senders received any kind of mail notification? Have you tried to connect to your server from another network? Is it accessible? – Pavlos G. Jul 8 '11 at 12:19
yes, the server is accessible from another network. it returns this all relevant MX records point to non-existent hosts but my records are correct. – MattBH Jul 11 '11 at 7:00
Perhaps you should try some nslookup queries to several DNS servers in order to check that your MX records are updated correctly. – Pavlos G. Jul 11 '11 at 17:29
i don't know if this helps but, previously i had centOS 5.6 installed where i had the exact opposite i could receive mail but could not send mail, and the records were exactly the same. – MattBH Jul 12 '11 at 8:42
Find out why point to non-existent hosts and fix that. – cweiske Jul 14 '11 at 7:54

Do you have a firewall enabled? If yes, open the SMTP port.

The port is at:

$ cat /etc/services|grep smtp
smtp        25/tcp      mail
ssmtp       465/tcp     smtps       # SMTP over SSL
share|improve this answer
which port is the smtp port? – MattBH Jul 14 '11 at 6:53
these are the tcp ports open in my firewall: 20,21,22,25,53,80,110,143,443,3306,8080,8081,10000 – MattBH Jul 14 '11 at 7:26
okay so i've added the 465 port to the firewall list, but still not able to receive external mail – MattBH Jul 14 '11 at 7:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.