Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having issues with backing up hidden folders from an Ubuntu installation.

My kids PC motherboard recently died. I've built them a new system, but it's a different processor/architecture, so the old hard drive doesn't boot in the new system. I can access the drive by booting to a live CD, and get all the regular files.

I don't seem to be able to access the hidden files to back them up. I'm sure I've done this in the past with other disks and had no issues with accessing all files. I've checked the disk itself and it reports no errors.

I can see the folder names, but when I try to browse into them, or copy their contents, I get an error like this:

The folder contents could not be displayed.

You do not have the permissions necessary to view the contents of ".WorldOfGoo".

  • I know all the user names and passwords for the various users.
  • None of the folders were encrypted or protected in any way.
  • File system is ext4

Does anyone have any idea how I can I back these folders up before re-installation?

share|improve this question
2  
Have you tried using gksu nautilus to copy? –  enzotib Jul 8 '11 at 7:52
    
You can install Ubuntu leaving the old /home directory untouched. –  Takkat Jul 8 '11 at 10:56
    
That was it enzotib. I thought about doing that Takkat, but figured a clean install was a better option, and wanted to back up the files in case it all went badly, which, BTW, it didn't. The kids are happily computing again, will all their pictures, favourites and email intact. –  John T Jul 12 '11 at 0:30

1 Answer 1

up vote 1 down vote accepted

I am sure you have tried this already but have you done what I usually forget to do which is select see hidden files or press ctrl and H in nautilus.

I would also try to open nautilus as root as suggested by enzotib or using the command sudo nautilus in a terminal.

That is I am sure what I did one of the last times I messed up

share|improve this answer
    
Yes, I had hidden files visible, I just couldn't copy them,. After messing around for a little while, I realised I was working under the mistaken assumption that the live CD user has root priveleges. Running a nautilus session as root allowed me to copy the files as intended. > gksudo nautilus is the way I did it. Can anyone remember if the Livce CD user ever ran as root? –  John T Jul 12 '11 at 0:28
    
It was how I remembered it from the many times things have gone pear shaped here!. Glad it got sorted! –  andybleaden Jul 12 '11 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.