Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Several special keys, most importantly the 'eject' button, are not working on my keyboard.

The only way I can eject my DVD drive is by opening up a terminal and typing 'eject'. When I press the eject button on my keyboard it gives the following message in the logs so it is registering the button being pressed but it is not doing anything. Also it doesn't register this message in the logs everytime i press the eject button, only occasionally.

-laptop kernel: [ 1335.617380] atkbd.c: Unknown key released (translated set 2, code 0xf8 on isa0060/serio0).
-laptop kernel: [ 1335.617384] atkbd.c: Use 'setkeycodes e078 <keycode>' to make it known.

Does anyone know how I should go about fixing my keyboard so that all my special keys like eject work?

I installed Keytouch and Keytouch editor but when it asks me to press the 'eject' button it still doesn't notice that I pressed it so I can not assign it to the XF86Eject function. Its a Packard Bell EasyNote TX86 and I'm running Lucid Lynx. Any ideas?

share|improve this question
add comment

1 Answer

Install KeyTouch. If your keyboard is not supported out of the box, you need both the keytouch and keytouch-editor packages. Run the keytouch editor, and configure your keyboard (it's probably not exactly a 9205, possibly completely different, given that the 9205 is not a laptop keyboard).

The reason xev doesn't see the multimedia keys is that the kernel doesn't transmit them if they haven't been properly introduced (that's what the “unknown key released, use setkeycodes” messages mean). KeyTouch will do it (in a more user-friendly way than setkeycodes), and will also handle the higher-level aspects such as configuring the eject key to eject the CD.

The Right key not working is a bit worrying however. Does it trigger kernel messages? It should have worked out of the box, since it's a standard key.

Other relevant Ubuntu wiki pages are Hotkeys/Troubleshooting (but try KeyTouch first) and Hotkeys/Architecture (explaining this is not as simple a it should be under the hood).

share|improve this answer
    
thanks, this question has changed quite a bit now as when i reinstalled ubuntu i no longer had any problems with my right key, still having problems with 'eject' though. –  cilliano Oct 6 '10 at 16:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.