Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to run some MP4 videos on SMplayer , but the player is only playing the audio, and no video is visible. The same file I open in VLC player is showing video + audio. I like SMPlayer, as its better in usability, therefore looking for the solution of playing MP4 files in it.

Thanks

share|improve this question
    
have you installed ubuntu-restricted-extras and w32codecs? –  fossfreedom Jul 8 '11 at 9:32

2 Answers 2

For Playing Restricted Formats install ubuntu-restricted-extras

sudo apt-get install ubuntu-restricted-extras
share|improve this answer
    
isn't that only for gstremer based apps¿ –  xangua Jul 8 '11 at 13:44
    
nope - all apps that want to play these media files (except VLC, which come with it's own) –  Conor Rynne Jul 8 '11 at 14:09

smplayer probably not working because video ID is set to 0.

don't know about other SW, but for me it worked, when I put into ~/.config/smplayer/smplayer.ini

under section [%GEneral] put: (without quotes) "current_video_id=1"

Hope it helps

share|improve this answer
    
Thanks! For what it's worth, this also solved the problem for me with SMPlayer on Windows. –  Joseph Sturtevant Aug 23 '13 at 15:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.