Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I compile and install tarballs using the usual ./configure, make, sudo make install, the files and directories created always have wrong permissions. In particular, nothing that should have the group and user execute bits actually has them. I've been making do by tee-ing a copy of the make log and chmod-ing things as appropriate, but that's gotten increasingly annoying.

For example, I just tried to install the latest version of OCaml by its tarball using ./configure, make world, and sudo make install. The result is that every /usr/local/bin/ocaml* has permissions 0744 rather than 0755 as you'd expect. Subdirectories in /usr/local/lib/ocaml/ also have 0744 bits, preventing anyone who's not root from using those libraries.

umask 022 before make install in a root shell is fruitless, as well. Furthermore, I have never had this problem with non-Ubuntu distributions, for what that's worth.

Like I said, this happens with all tarballs I use, so an answer like "sudo apt-get install ocaml" is missing the point.

Thanks.

share|improve this question

closed as too localized by fossfreedom Mar 18 '12 at 9:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What is the umask of your user (when compiling)? –  enzotib Jul 8 '11 at 5:34
2  
Do the files in the compilation tree (e.g. ocaml) have 744 permissions as well? In addition to your umask, do you have strange mount options (post the output of mount)? –  Gilles Jul 8 '11 at 6:19
    
default umask of the user you are compiling can be found by issuing 'umask' from terminal. –  Jamess Jul 8 '11 at 11:53
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  fossfreedom Mar 18 '12 at 9:01