Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a recent firefox upgrade, the integration with the unity launcher went pear-shaped. Clicking on the Firefox icon does not move focus to the running firefox, but starts another firefox instance / window. I tried removing it from the launcher and re-adding it but I couldn't re-add it in any way except adding a Firefox shortcut launcher to the desktop and adding that to the launcher, but the same problem persists where clicking on the icon just opens new Firefox windows instead of bringing up the existing window.

I'm running Ubuntu 11.04 64 bit with normal Unity desktop.

Is there a way to reset the configuration of the launcher to work normally with Firefox again?

share|improve this question
add comment

3 Answers

This works for me:

  1. Completely quit Firefox (File | Quit)
  2. Remove your existing Firefox launcher from Unity
  3. Hit Alt+F2, type 'firefox' to filter results, and drag the result into the Unity bar

[edited to replace earlier not-working solution]

share|improve this answer
    
Running Firefox like that (or any other way) does not cause the Firefox icon to appear in the bar. Thanks for the suggestion, though :). –  postfuturist Jul 8 '11 at 0:31
    
It makes it appear for me (though it's best if you quit Firefox before adding its icon to the bar, btw). However, the icon that shows up doesn't work for me. darn. :) I just tweaked the solution to something that does work for me -- give that a shot? –  dholbert Jul 8 '11 at 17:01
    
When I drag the firefox icon to the menu nothing happens, it just disappears when I drop it. –  postfuturist Jul 8 '11 at 20:30
    
RE "it just disappears when I drop it." -- That only happens for me if it's already there in the Unity dock. Are you sure you've got all Firefox-ish icons removed from the dock? If so, I don't know what's going on -- sorry :-/ –  dholbert Jul 8 '11 at 20:44
1  
solved by a reboot :| –  postfuturist Jul 11 '11 at 20:45
add comment
up vote 1 down vote accepted

I rebooted my computer and the problem got resolved on its own.

share|improve this answer
add comment

Dragging it onto the launcher didn't work for me. I still had the same issue. I ended up dragging the firefox shortcut to the desktop and then to the Launcher. If the shortcut is deleted from the desktop it is also removed from the launcher.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.