Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Anybody successful on installing this printer on amd64 please?

Canon supplies 32bit drivers -- as *.deb and also as source: http://www.canon.com.au/en-au/For-You/Printers/PIXMA-InkJet-Printers/MX350 Current compilation failed ... Trying to install the i386 debian packages worked somehow ...

as of 2011-11 there's an awesome ppa repository:

How can I install a Canon driver?

share|improve this question
2  
you should move much of your question into an answer so you can accept it. Well done. Upvote from me. –  fossfreedom Jul 7 '11 at 20:13

3 Answers 3

up vote 3 down vote accepted

I do not know why, but I can print now -- also wireless.

  • once supplied the PPD from the canon driver source archive, but deleted the printer again as it complained about missing filter
  • tried to compile source as stated above
  • tried to force install of i386 packages as above
  • added the printer once again and it found it as shown in the screenshot below

enter image description here


Even scanning works!

enter image description here

share|improve this answer

Have you installed the sudo apt-get install ia32-libs package? That's what I need for my printer on 64 bit Ubuntu.

share|improve this answer
    
Thanks, trying to force the i366 .deb is prevented by some unmet dependencies -- added output above. Cheers –  type Jul 7 '11 at 19:40

My MX350 on 11.04 wasn't working either. I had ia32-libs installed, but the install of cnijfilter-common_3.30-1_i386.deb still complained of missing i386 deps. I tried manually installing a few but they were already present. So I went ahead and added the "--force-depends" option

sudo dpkg -i --force-architecture --force-depends cnijfilter-common_3.30-1_i386.deb

and re-added the printer, and everything seems to be working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.