Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

recently i wanted to increase flash performance by installing the flash aid extension for firefox. this step has broken my flash, and now i can't watch youtube videos in full screen. i get a black screen after it was fine before.

I did remove the FF extension and I did try to completely remove the ubuntu restricted extras, but it won't let me do so, How do i restore the flash settings and completely remove the settings so i can get back to the original settings?

note that if i try to remove ubuntu restricted extras, it does try to install kubuntu restricted extras, at the same step.


share|improve this question
up vote 1 down vote accepted

Problem solved. i reinstalled the flash-aid plugin in firefox, then proceeded with the wizard mode, but this time, unlike the first time, i did NOT choose the option of tweaking gpu validations. that did the trick.

share|improve this answer
This is a temporary YouTube issue. Disabling the GPU Override solves the problem. See – lovinglinux Jul 7 '11 at 18:48
Just updated Flash-Aid to get the new Flash 11 Betas, for both 32bit and 64bit. If you already use Flash-Aid, all you need is to execute the Wizard to install. Hardware acceleration and the performance tweak "Override GPU validation" is working on YouTube again. No more black screen. If you already use Flash-Aid, you probably will receive an alert tomorrow, since it only checks for updates once a day. But if you run the Wizard today, you can ignore that alert. – lovinglinux Jul 13 '11 at 22:59

Reinstall the package flashplugin-installer:

sudo apt-get --reinstall install flashplugin-installer

It should work.

share|improve this answer
i did try that, and restarted. problem persists – suli8 Jul 7 '11 at 16:00
i did find the trick, workaround. i re installed the flash aid plugin, and running it's wizard mode, i didn't choose the option of tweaking the gpu validation, and that's it now i have full screen! please write this on your answer so i can accept it right now. – suli8 Jul 7 '11 at 16:50
I cannot write your finding in my answer. You can write your own answer and also accept it. – enzotib Jul 7 '11 at 16:57
yeah ok. no problem. i just thought it will be faster this way. if i write my own i could accept it after 48 hours or so... and it doesn't matter who writes it, the important thing is that the answer is here for others. i will write it now. thanks. – suli8 Jul 7 '11 at 17:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.