Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From time to times I have to reboot my Ubuntu 11.04 remote desktop. Once it up and I run Cromium browser with many tabs (20 for example) dns server doesn't respond anymore. At beginning I suspected my ISP, so I replaced my /etc/resolv.conf with following values:

nameserver 208.67.222.222
nameserver 208.67.220.220
nameserver 8.8.8.8

The result is the same - I can't use browser for ~20 min. because names are not resolved, ping doesn't work either.

Any idea what is blocking?

share|improve this question
    
When you say ping doesn't work either do you mean IPs also? Or just names? Can you ping 8.8.8.8? –  Mr Shunz Jul 7 '11 at 11:49
    
I meant just names. During that time I'm able to connect remote machine and some services, like skype, are able to connect to internet (I suppose Skype use IP address). –  Dzidas Jul 7 '11 at 12:17
    
did you try removing the first two values? For me, I completely removed my ISPs DNS entries, and hardcoded (and subsequently write-protected) my list of nameservers... I use 8.8.8.8 and 4.2.2.4 and they work fine. –  Thomas W. Jul 7 '11 at 13:05
    
The first two are OpenDNS entries, not my ISP. –  Dzidas Jul 7 '11 at 13:09
    
regardless if they're your ISP, did you try removing them and just leaving nameserver 8.8.8.8 just to see what happens? i just ran a DNS lookup off of 8.8.8.8, so I know its functioning. –  Thomas W. Jul 7 '11 at 13:12
show 2 more comments

3 Answers

Well, could really be a problem with your ISP DNSs and maybe they intercept DNS traffic and route it throurgh their servers...

Try a dig @8.8.8.8 www.ubuntu.com and see what happens.

Output should be like:

; <<>> DiG 9.7.3 <<>> @8.8.8.8 www.ubuntu.com 
; (1 server found) 
;; global options: +cmd 
;; Got answer: 
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54464 
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 

;; QUESTION SECTION: 
;www.ubuntu.com.      IN  A 

;; ANSWER SECTION: 
www.ubuntu.com.   497 IN  A 91.189.89.88 

;; Query time: 2307 msec 
;; SERVER: 8.8.8.8#53(8.8.8.8) 
;; WHEN: Thu Jul  7 14:23:41 2011 
;; MSG SIZE  rcvd: 48 
share|improve this answer
    
xxx@xxx:~$ ping www.google.com ^C xxx@xxx:~$ dig @8.8.8.8 www.ubuntu.com ; <<>> DiG 9.7.3 <<>> @8.8.8.8 www.ubuntu.com ; (1 server found) ;; global options: +cmd ;; connection timed out; no servers could be reached –  Dzidas Jul 7 '11 at 13:28
1  
Sounds like dns lookups are being blocked somewhere along the line. Can you ping 8.8.8.8? –  Thomas W. Jul 7 '11 at 13:53
    
x@x:~$ ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_req=1 ttl=54 time=81.8 ms 64 bytes from 8.8.8.8: icmp_req=2 ttl=54 time=31.9 ms 64 bytes from 8.8.8.8: icmp_req=3 ttl=54 time=29.0 ms 64 bytes from 8.8.8.8: icmp_req=4 ttl=53 time=29.4 ms ^C --- 8.8.8.8 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3004ms rtt min/avg/max/mdev = 29.084/43.069/81.809/22.394 ms x@x:~$ ping www.google.com ping: unknown host www.google.com –  Dzidas Jul 7 '11 at 14:13
add comment

Try installing the dnsmasq package and configuring it to cache DNS for you. This should cut down on your DNS queries and may prevent whatever is blocking you from activating. It could be a DNS rate limit filter somewhere in your chain.

Your /etc/resolv.conf for dnsmasq should consist of 127.0.0.1. I am not sure if the current installer sets this up.

share|improve this answer
add comment

You can also use Google's open dns:

so could edit /etc/resolv.conf:

# Googles Public DNS

nameserver 8.8.8.8

nameserver 8.8.4.4

search localdomain

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.