Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having issues installing 11.04 on my new laptop, the solution was to enable any of these boot options:

  • acpi=off
  • noapic
  • nolapic

But, what do these options actually do?

What sort of problems are there in enabling them?
i.e. can they cause hardware problems (like fans not running causing system overheating).

share|improve this question

2 Answers 2

up vote 11 down vote accepted

In general, such boot parameters are not needed unless there is a problem with your BIOS and how it handles these standards, or it just might be old enough where these standards were not fully implemented properly.

ACPI (Advanced Configuration and Power Interface) is a standard for handling power management. Older systems may not support ACPI full, so sometimes it helps to give the kernel a hint to not use it. "acpi=off"

APIC (Advanced Programmable Interrupt Controller) is a kind of feature found on newer systems. The "local" version is called "LAPIC". What this controller can do is be set up to generate and handle interrupts, a signal the hardware uses to pass messages. Again, some implementations of APIC can have problems on older system, and so it is useful to disable it. "noapic" and "nolapic".

Sometimes the APIC is working, but it slows things down by getting in the middle of messages being passed around. This can mess with audio and video processing, for example. Folks might disable it for that reason as well.

share|improve this answer
2  
Thanks :) Just one comment, my laptop is a brand new laptop only released a couple of months ago. So my issues are probably related to incompatible new technology, not old technology. –  Valorin Jul 7 '11 at 0:43
    
Same issue for me. I have a rather recent HP Mini netbook, on which Ubuntu 10.10 works just fine. But I cannot even boot the live CD on it without this acpi=off boot parameter. –  jfmessier Jul 7 '11 at 1:52
    
If you are having trouble booting with ACPI enabled, check to see if there are any BIOS upgrades available. With ACPI enabled, the kernel delegates certain tasks to ACPI scripts stored in the BIOS. If those scripts are buggy, then it can lead to kernel level instability. So BIOS bug fixes can help here. –  James Henstridge Jul 7 '11 at 4:29

Same problem here, with an not that old HP notebook. I have installed on it the Lubuntu 13.10 beside Windows7 and an old kernel from Linux-Mint.

Now, I need to edit the grub every time I like to start the notebook, is there a method to fix this in the grub, so the grub keeps the options "noapic" and "acpi=off", I do not have any idea at the moment, just need a hint.

Thanks in advance.

I know my problem does not answer the thread, but I do have the same problem as the other user, well so far I solved it by setting the options in grub.cfg, in the directory /boot/grub/ in each line where it calls up the linux image I added

noapic acpi=off pnpbios=off.

Now the notebook starts up from hd0.

share|improve this answer
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  Elder Geek Jan 15 at 20:56
    
You can add those options to /etc/default/grub file and I believe ot is line with 'splash' option. Can't add much more details as I'm in phone right now –  Serg Jan 15 at 21:30
    
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  Aibara Iduas Jan 16 at 0:22
    
Jürgen, Welcome to AskUbuntu! ;-) We're sorry but that's an "answer" you posted, so the only people looking at this are the original poster and a bunch of reviewers who will only be interested in deleting your "answer". Look elsewhere on the site for a real answer and if you find none, ask a new question. ;-) –  Fabby Jan 16 at 1:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.