Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old Acer TravelMate 2410 laptop, that was running XP. I've decided to dump XP, and install Xubuntu.

I did a clean install, and done all the updates that are available. Everything is running as it should with the exception of reboot and shutdown. The system will not do either, and it gets stuck.

below is what I've tried so far, and nothing have helped so far. There is no option in the BIOS to disable booting from LAN, or any other PM settings.

The system has Intel 910GML integrated 3D graphics featuring Intel GMA 900

I changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off

I did

sudo gedit /etc/modules

and added

apm power_off=1 below lp 

I also changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

I also changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"

I also changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci"

I also changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=oldboot"

Nothing worked.

enter image description here

share|improve this question
    
have you checked and installed the latest BIOS for your laptop? Are there any dmesg messages displayed when you invoke a shutdown - should give an idea of what is going on. Any BIOS options that say "S1/S2 or S3"? - this might need to be set. –  fossfreedom Sep 4 at 11:36
    
BIOS is at the latest available version, and no option for S1/S2 or S3. I've added `dmesg' in my question. –  Mitch Sep 4 at 11:47
    
drastic - does booting with the kernel option acpi=oldboot work with the shutdown process? There are a bunch of other kernel boot options as well you can try - help.ubuntu.com/community/BootOptions –  fossfreedom Sep 4 at 11:53
    
@fossfreedom that didn't help either. –  Mitch Sep 4 at 12:00
    
what is the outcome of running sudo shutdown -P now or sudo poweroff ? Still getting a halted system? –  Anders F. U. Kiær Sep 4 at 12:31

1 Answer 1

up vote 2 down vote accepted

I have an Acer TravelMate 2410 and this is the solution that worked for me:

  1. Open 'Terminal'
  2. Type: sudo nano /etc/modprobe.d/blacklist.conf
  3. Add a new line at the end that says: blacklist wistron_btns
  4. Save the file (press 'ctrl+o' and then 'enter')
  5. Exit (press 'ctrl+x')
  6. Reboot the laptop.

After you restart Ubuntu you can succesfully shutdown your laptop! If you are wondering why you are doing this: The module 'wistron_btns' crashes when you shutdown Ubuntu. It is supposed to manage the WiFi kill switch and "special" buttons on the laptop.

I found this solution here

share|improve this answer
    
Great job. It worked. Thanks...:) –  Mitch 16 hours ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.