Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Dell XPS M1330 gets very hot when im running Ubuntu 11.04 (or any earlier editions) It's running cool and nice in Windows 7 and Vista.

It's so hot that's not comfortable to touch the palm rest.

What can i do to get it to cool down like in Windows 7?

share|improve this question

closed as too localized by htorque, jokerdino, jrg Feb 25 '12 at 13:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
It might be a problem of HDD activity, Do you have a SWAP partition? –  ashams Jul 6 '11 at 2:24
    
please, add measured temperatures in windows and in ubuntu ( to see which part is probably overheating ). help.ubuntu.com/community/SensorInstallHowto . For graphic card, install nvclock and then run nvclock -T in terminal –  Denwerko Jul 6 '11 at 9:17
    
This question appears to be abandoned as there hasn't been any activity for a longer period of time. I'm voting to close it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it reopened. Thanks! –  htorque Feb 23 '12 at 17:47

3 Answers 3

you can try setting ondemand scaling governor for your cpu

sudo -s 
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo ondemand > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor

more on sensors indicator here : Is there a hardware temperature sensor indicator?

share|improve this answer
    
nVidia Geforce 8400M GS => GPU temperature: 64C acpitz-virtual-0 Adapter: Virtual device temp1: +44.5°C (crit = +104.0°C) coretemp-isa-0000 Adapter: ISA adapter Core 0: +44.0°C (high = +105.0°C, crit = +105.0°C) coretemp-isa-0001 Adapter: ISA adapter Core 1: +44.0°C (high = +105.0°C, crit = +105.0°C) Yes i have a swap partition. I need to have the computer running a little longer before it heats up –  rvenes Jul 7 '11 at 2:54
    
if you havent tried commands above, please add here output of command "cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor" –  Denwerko Jul 7 '11 at 7:59

If the M1330 suffers from the same diseases as the M1530, you should talk to Dell to get your motherboard replaced. The built-in ones came with a fault which made them very prone to overheating. If you have your guarantee active, this should be no hassle. To get your motherboard replaced, you need to talk to Dell support - they might as well prove me wrong and give you a different fix.

share|improve this answer

you are facing the same issue which I faced in my Dell Studio 1555 laptop. Mostly it is caused by bad SATA link power management due to which your HDD is getting too hot, which is present under the palm rest.

Install powertop and run it in superuse mode: sudo powertop.

In your case it should show you Bad.

enter image description here

Solution:

  1. Install TLP as mentioned in the link.
  2. Open /etc/default/tlp
  3. Search for: SATA_LINKPWR_ON_AC in that file. Make the changes as follows:

    SATA_LINKPWR_ON_AC=min_power

    SATA_LINKPWR_ON_BAT=min_power

  4. Reboot the machine

It took me months to figure out what was causing this issue and got to know after opening my laptop to check what component is beneath the palmrest. :) I hope it is helpful for you.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.