Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.04, and I'm trying to install TortoiseHg. I've applied the PPA from TortoiseHg's website, so that apt-get can actually find it. But whenever I type sudo apt-get tortoisehg, I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tortoisehg : Depends: mercurial (>= 1.8) but 1.7.5-1ubuntu1 is to be installed
E: Broken packages

I understand what this means: I need to install Mercurial 1.8. The problem is that I can't. If I try sudo apt-get install mercurial, it says that 1.7.5 is the latest version, which it most certainly isn't.

So how do I convince this thing to install a more recent version of Mercurial?

I tried the commands from this answer to install Mercurial, but that didn't help. It again said that Mercurial was up to date.

share|improve this question

1 Answer 1

Use the mercurial PPA

apt-add-repository ppa:mercurial-ppa/releases
apt-get update 
apt-get install tortoisehg
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.