Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu 14.04.01, but I ran into serious problems (details here)

I have installed 12.04.05 instead, but I still have serious problems. After installing I reboot, the system starts ok, a window opens up about upgrade to 14.04, I decline and the window closes. I can see the bar at the top of the screen, but launcher is missing and now the ui is frozen: I can't click anything, right-click won't open the menu.

When I press ctrl-alt-f1 there is a error message at the tty:

could not write bytes: Broken pipe
-

[   929.157700] nouveau E[   DRM] GPU lockup - swithing to software fbcon

If I idle on the tty these messages appear:

[ 1070.992016] nouveau E[Xorg[1083] failed to idle channel 0xcccc0000 [Xorg[1083]]

There are several of them, the numbers change, but the text and the channel stays the same. If I idle long enough the desktop is swithced on and I have to log in and the top bar is missing.

My computer: Intel D865PERL, Pentium 4 CPU (3 Ghz), 3 Gb RAM, and NVIDIA Quadro FX 500/600 graphics card. I have a harddrive with two partitions: one for the XP and one for Ubuntu and it's partitions.

I think the problem is with the drivers, so I press ctrl-alt-F1 and install the drivers using these instructions via tty :

sudo add-apt-repository ppa:xorg-edgers/ppa -y
sudo apt-get update
sudo apt-get install nvidia-173

Then I type lspci -vnn | grep -i VGA -A 12 and everything seems ok except that Kernel driver in use: nouveau The next line is Kernel modules: nvidia_173, nouveau, nvidiafb

After reboot I get this enter image description here After this "OK" -> "Reconfigure graphics" -> "Use default (generic) configuration" OR "Use your backed-up configuration" -> nothing happens

If I choose "use low-graphics mode just for this session" the system freezes.

How could I solve this? I seems clear that the problem lies with the Nvidia driver. Would it help if I changed the kernel driver from nouveau to nvidia_173 ? How can I do that? I can find advice on how to do it in unity with dash, but how can I do it in tty?

SOLUTION: Using the latest drivers helped. I should have installed the 304 version in the first place instead of the 173 version I used (that was the version I used in my XP)

share|improve this question
1  
Possible duplicate of askubuntu.com/questions/141606/… –  saptarshi nag Sep 2 at 13:56
    
The link is good but your nvidia driver is clearly outdated and most probably can't work with your kernel. Current version is at least nvidia_340 !!! –  Pyrophorus Sep 2 at 14:00
    
@Pyrophorus: According to the Nvidia's list of legacy drivers (found here: nvidia.com/object/IO_32667.html) 173 is the correct one for Quadro FX 500/600, that's why I used it. But I did as you adviced and now Unity works! Finally! Thanks a lot! The only problem is that the maximum resolution is 1280 x 1024 and the system thinks my monitor is a laptop. I'll try to fix that one next. –  Leo Van Aerschot Sep 2 at 14:58
    
Magic ! Reply to your own question if finally you fix completely the problem ! –  Pyrophorus Sep 2 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.