Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We have ricoh "aficio mp c6501" in my job and I try to print from ubuntu 11.04. But it prints some hundred white pages.... When I install the printer, Ubuntu found it but when I try to print.... only white pages.

I try to find drivers from Ricoh, but they had only for windows. I find this site (Brightq) http://ricoh.codehost.com/

Did anyone use this drivers?

share|improve this question

7 Answers 7

i have the same problem of spitting paper on a ricoh aficio 3025 (open the tray to erase the job the only way). i do this:

1)install as a smb windows printer chossing a generic driver, and a "Generic PCL 6/PCL XL Printer - CUPS+Gutenprint v5.2.8-pre1" in the next selection

2)later go to properties of the printer and change the uri "socket://xxx.xxx.x.xxx:yyyy" the "yyyy" is the port printer (appears in the original uri)

try it.........works ok, good luck

share|improve this answer

Most laser printers (including copiers) can use the generic postscript driver that's available from the driver selection screen when you add a printer. Try that driver and see if it works.

share|improve this answer
    
The problem is that, I connect the printer but when I try to print a file, printing white pages. –  Vassilis Sep 1 '11 at 8:53
    
@Vassilis: Did you try the generic postscript driver? –  Scott Severance Sep 6 '11 at 0:06
    
How can install it and use it? –  Vassilis Sep 6 '11 at 6:12
    
When you add a printer, you're asked to select your printer make and model. Instead, choose generic as the make and postscript as the mode. –  Scott Severance Sep 7 '11 at 2:43

On OpenPrinting website I've found PPD file for your printer c6501:

and search for c6501.

I've a Ricoh Aficio MP C2551 printer, scanner and photocopier but also installing providing the ppd downloaded from OpenPrinting doesn't work for me.

Files aren't printed right. For every print I receive a first page with some informations and next a lot of blank pages:

%!PS-Adobe-3.0
              %% %%
                   mark
                       () () (201201181644) {setuserinfo} stopped
                                                                  cleartomark
                                                                              %%

I'm on Ubuntu Oneiric 11.10.

On OpenPrinting website for your printer C6501 and also for my printer C2551 it's reported that they works "perfectly"

Any advice?

share|improve this answer

I had the same problem after upgrading in 12.04 with the MP 2510. I try to choose the PXL and not PS driver and then it prints fine.

share|improve this answer

FIXED, I am running Ubuntu 12.04 LTS and printing through network LAN to a RICOH MP C2050, I got the same problem above followed by paper spitting out at a furious rate!

(1). Install CUPS Gutenprint v5 through repos and then try again after deleting old printer, this time when you choose the RICOH > Aficio MP C2050 driver there will be the Gutenprint option now, ignore recommended and choose Gutenprint! Test print. if thay does not fix, then do (2).

(2). Go through setup when finished go to printer right click > Properties and change make/model to RICOH Aficio MP 2000

This worked for me... Hope it helps, RICOH are fussy Good Luck!

share|improve this answer

I had the same problem with an Ricoh Aficio 3025 printer. I solved it simply by doing the following steps:

  1. Install printer normally from the System Settings -> Printers
  2. Download PPD print driver from The Linux Foundation Open Printing Project
  3. Browse to System Settings -> Printers -> select the printer and edit properties.
  4. In the Settings tab select change make and model.
  5. Select provide new ppd file.
  6. Select the downloaded driver.

and you are ready to go.

share|improve this answer

I had a similar issue, using SMB and choosing the PS driver for the specific printer jst resulted in endless 400 page test jobs of jibberish.

I tried this slight variation on the method mentioned above and it worked flawlessly (Ricoh MP6001 and Ubuntu 12.04 LTS 64 bit)

1)install as a smb windows printer choosing a generic driver, and a "Generic PCL 6/PCL XL Printer - CUPS+Gutenprint v5.2.8-pre1" in the next selection

2)later go to properties of the printer and change the uri from SMB.... to "socket://xxx.xxx.x.xxx" (x's being the IP of the printer obviously)

3.) Save changes then print a test page.

Thank you to the original poster, it's great to finally be able to print to my office printer via my Linux machine!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.