Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I installed Ubuntu 11.04, I checked the box to encrypt my home folder. Today, I set my account to log in without a password to allow my friend to borrow it. However once you click to log in. It says that Nautilus cannot find/create a directory for /home/USERNAME/Desktop and all I get is a blank screen (default 11.04 purple background and no Unity. My keyboard shortcuts work, but nothing exists on the screen.

share|improve this question
add comment

3 Answers

As you probably know it's not possible to have an encrypted home folder without a password. The login password was used to encrypt the folder, if the computer doesn't know it, it can't decipher your home folder.

As this is the whole point of an encrypted folder, you just can't have both things at the same time (encrypted folder and automatic login).

You have a couple of workarounds:

  • Create a new user account for your friend. Get sure that it's home folder is not encrypted and set the computer to autolog to this account. You will need to add it to the superuser group to allow him to do administrative tasks.

  • You can also disable encryption in your home folder, Jonik answer to this question is quite straigh forward.

If you need to disable the autologin from the command line, check this enzotib answer. If you are not able to log to the GUI, you can usually access the command line pressing CTRL+ALT+F1.

If this doesn't work boot into recovery mode and follow the enzotib guide. You can usually select recovery mode on the grub screen, the first menu that appears when booting, where you can select the OS that will be loaded. If you don't see this screen try to press shift while booting.

share|improve this answer
    
I'm actually typing this now because I installed an older version of Ubuntu alongside my 11.04 install and am using that. I have mounted my 11.04 harddrive and can edit its files from this, but if I try to boot into it then there's nothing. No desktop, no applications, no launcher, no panel. –  Leron Jul 6 '11 at 2:39
    
Also, I'm not seeing Jenit in the answer's to that question. Did you mean Joink or is that an incorrect link? –  Leron Jul 6 '11 at 2:57
    
Sorry, I mean Joink. I added some info to let you reach the command line. –  Javier Rivera Jul 6 '11 at 7:17
    
@binw: Thanks, I must have some kind of strange problem with names. –  Javier Rivera Jul 6 '11 at 9:11
    
@Javier-Rivera: you must be a programmer :) we see bits everywhere –  binW Jul 6 '11 at 9:58
show 3 more comments

If I'm not mistaken you need your password to decrypt your home folder password, so that won't work since it just lets you bypass gdm, it doesn't save your password nor it can unlock your keyring.

Its best to create a new user for your friend.

share|improve this answer
add comment

Restart your computer, boot into recovery console, select "Drop to the root command line", type passwd, change to your original password, restart the computer and log in hopefully like earlier.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.