Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there any way to stop Chromium (or Google Chrome) from auto-completing searches in the address bar?

The best example of this I have seen is, if you type fire and ice into Chromium’s omnibox and hit Enter, it searches for fire and ice. If later you type fire into the omnibox and hit enter it “autocompletes” the search and again searches for fire and ice, not just fire.

I find this very frustrating and would just like a way of stopping this behaviour.

share|improve this question
add comment

1 Answer

  1. Click on the menu (the icon with three lines in the top right of the browser)
  2. Click "Settings"
  3. Click the "Show Advanced Settings" link at the bottom of the page.
  4. Uncheck the box for "Use a prediction service to help complete searches and URLs typed in the address bar or the app launcher search box".

enter image description here

share|improve this answer
    
Thank you for trying to help but I just tried this answer and it didn't work :( if it helps at all I'm using Chromium 14.0.812.0 (Developer Build 91482 Linux) Ubuntu 11.04 –  Roo79x Jul 5 '11 at 11:37
    
select Clear Browsing Data and it will work, I have just installed the development build of Chromium to test this out and it does work. –  scouser73 Jul 5 '11 at 12:50
    
Thank you again for your time I've been following your every instruction I've even tried this on my mac with google chrome , I've purged chromium on my linux laptop and reinstalled the stable build and that didn't help either?. I'm not sure what I'm doing wrong I've taken some screen shots and they are here for you to see picasaweb.google.com/roo79x/… –  Roo79x Jul 6 '11 at 5:12
    
and look here google.com/support/forum/p/Chrome/… and here google.com.au/… to please from what I read I'm not the only one with this problem. –  Roo79x Jul 6 '11 at 5:25
    
I was looking at the search engines under Preferences>Basics> Manage Search Engines. and I found that the default Google search URL looked like this {google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQu‌​eryForSuggestion}sourceid=chrome&client=ubuntu&channel=cs&ie={inputEncoding}&q=%s regardless of what I set in my preferences or my browser data. but creatingmy own google search engine and using google.com.au/#hl=en&source=hp&q=%s it will not?? –  Roo79x Jul 6 '11 at 11:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.