Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 64Bit Ubuntu installed, and a MSI Graphics card.

Any ideas on why this might be happening?enter image description here

share|improve this question
2  
How are you determining that you only have 3.2Gb? Please post the output of uname -a and free -m here. Both of these commands are run in the terminal which you can open by doing ctrl+alt+t –  crasic Jul 5 '11 at 6:11
    
@crasic he's going by the Mem line's total column. –  Thomas W. Jul 6 '11 at 19:52
    
what does your BIOS think you have for memory? –  DrSAR Jul 6 '11 at 23:16
    
5gb show in bios –  TheX Jul 7 '11 at 2:26
    
What does this show cat /proc/meminfo –  tgm4883 Jul 11 '11 at 0:52

4 Answers 4

up vote 6 down vote accepted

Check in the motherboard BIOS for an option similar to "map around memory hole." Your motherboard's chipset may not support this option.

Older, especially laptop, chipsets (for example, the Intel 945p chipset) did not support true 64 bit memory addressing and had a ceiling of 4GB even in 64 bit mode. If that is the case with your system then this is a hardware limitation that can't be addressed without replacing the chipset (motherboard.)

share|improve this answer
1  
No option in BIOS, I guess it could be the processor –  TheX Jul 6 '11 at 19:38
    
@TheX What is the motherboard's chipset? –  Andrew Lambert Jul 6 '11 at 20:49
    
@TheX @Amazed it might be easier to just post the model of the motherboard so we can look up the chipset –  crasic Jul 6 '11 at 21:59
    
I will have to look will let you know –  TheX Jul 7 '11 at 2:27

Is it an integrated VGA? In that case, some will share the main memory, so it won't be available to applications.

share|improve this answer
2  
Dedicated video as I mentioned before –  TheX Jul 6 '11 at 19:38

Is the missing memory on the graphics card or memory in your computer? How have you determined that only 3.2GBs are showing up?

If it's a matter of available memory, you might check System Monitor (in System Settings) and look under the Processes tab, and then click "Memory" to put the processes in order so you can easily see which are using the most memory. The Resources tab will show total memory in your system, as well as how much is being used.

share|improve this answer

You need to install pae kernel. This will allow usage of memory on a computer larger than 4GB

Most times you can install with:

sudo apt-get install linux-generic-pae

Once you restart you should see the correct memory size.

share|improve this answer
1  
This is invalid. The post already states that he is using 64-bit Ubuntu –  tgm4883 Jul 11 '11 at 0:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.