Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm using apt-cacher-ng to cache package downloads for my LAN. I'm also using the Ubuntu Beta fonts PPA which requires a password for access. I keep getting the error

bjorn@bjorn-laptop-natty:~$ sudo apt-get update
[sudo] password for bjorn: 
Ign natty InRelease
Ign natty/main amd64 Packages/DiffIndex      
Ign natty/main TranslationIndex    
Err natty/main Sources             
  Failed to connect to Invalid argument
Err natty/main amd64 Packages                
  Failed to connect to Invalid argument
Ign natty/main Translation-en_US             
Ign natty/main Translation-en                
Hit natty Release.gpg                             
Hit natty-updates Release.gpg                     
Ign natty-security/universe Translation-en          
Fetched 72 B in 7s (10 B/s)                                                    
W: Failed to fetch  Failed to connect to Invalid argument

W: Failed to fetch  Failed to connect to Invalid argument

E: Some index files failed to download. They have been ignored, or old ones used instead.

It works properly if I disable using apt-cacher-ng. It seems weird that it says that it is trying to connect to; I'm pretty sure that's not the address of launchpad's PPAs. I don't always want to be changing settings just to check for updates, so how can I make apt-cacher-ng and a passworded PPA work together?

share|improve this question

1 Answer 1

up vote 7 down vote accepted

You can bypass apt-cacher-ng for certain hosts by using lines like the following in /etc/apt/apt.conf or the configuration file in /etc/apt/apt.conf.d/ "DIRECT";

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.