Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got the following error while attempting to upgrade from 8.04 to v 10.04. Is there anything I can do to resolve the issue?

Upgrading Ubuntu to version 10.04 LTS
Could not install the upgrades Error during commit
'E:Couldn't configure pre-depend jre for openoffice.org-writer2latex, probably a dependency cycle.'
Restoring original system state

share|improve this question
2  
Try installing a JRE (e.g., apt-get install openjdk-6-jre), possibly the one from the 10.04 repo, before trying the full upgrade. Does it work? –  Riccardo Murri Oct 4 '10 at 15:43
add comment

1 Answer

up vote 2 down vote accepted

Try

apt-get remove openoffice.org-writer2latex
apt-get dist-upgrade
apt-get install openoffice.org-writer2latex
share|improve this answer
    
thanks, I've uninstalled openoffice.org and the upgrade is now in progress –  Mark Heath Oct 4 '10 at 16:40
    
@Mark any update? –  badp Oct 10 '10 at 14:49
    
yes, the update worked after uninstalling open-office. –  Mark Heath Oct 11 '10 at 10:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.