Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP Pavailion G6 laptop which came preinstalled with Windows 8, but I tried Ubuntu and fell in love with it. I removed Windows to get more room for Ubuntu. The real problem arose when I needed to get a program developed by our institute which is currently made only for Windows machines. So I made a partition of 150 GB and tried to re-install Windows with a Windows CD. It gave an error that the disk is formatted by someone who doesn't understand GPT partitioning. Now the only option I know is to use diskpart from cmd, which I don't really want to do because I don't have ext HDD big enough to save all necessary data. So is there any way to convert just a disk partition (I do mean disk partition, not the entire disk) to MBR or Windows-supported GPT format?

Edit:Guys please don't give me suggestions for using VMware or wine.See the comments on first answer for VMware complications and commecnts on second answer for incompatibility with wine.

share|improve this question
    
If you only have the one Windows application to run, have you considered using a windows emulator such as wine to do this? –  Graham Aug 29 at 11:59
1  
or using virtualbox? –  AlexGreg Aug 29 at 12:21
1  
virtualbox is the way to go. wine is too difficult and it is unsure if that software is workable in wine. vbox on the other hand is an OS in an OS so all software will install as if it was a dual boot install. Works perfect for these kind of problems. –  Rinzwind Aug 29 at 12:28
    
Why such a large partition if you wanted space for Ubuntu? 30GB is more than enough for just a few applications –  ekaj Aug 29 at 15:45

4 Answers 4

Keep using Unbuntu.

If you absolutely need to run a windows program, don't mess around with partitioning, just download VirtualBox, install Windows in that and voilà, not only can you have your cake, you can eat it too.

share|improve this answer
    
come on yaar ,if I knw abut gpt n mbr partition types I may nt be that noob. Problem is that it requires 3D graphics acceleration causing both my Ubuntu n windows hang or I gt a lag in program. –  user314107 Aug 30 at 16:09
    
VirtualBox doesn't demand 3D graphics acceleration. –  Fred Bel Aug 31 at 9:22
    
but still its lagging like hell.Belive me ,I don't wanna switch back to windows either ,I only need to run this little piece of scum and I need a windows computer for it.Isn't there anything which I could do to convert gpt to mbr or even windows compatible gpt by formatting just a partition and not whole disk ? –  user314107 Aug 31 at 13:26
    
@user314107 If you are having big lag in VBox, there's a setting missing somewhere. Is your G6 running openGL? –  Charles Green Aug 31 at 13:43
    
Once you run an OS in VirtualBox, you need to download Guest Addition for that OS. Guest Addition allows VirtualBox to run seamlessly with your Host OS. –  Fred Bel Aug 31 at 18:09

Another alternative to using a virtual machine, is to use a Windows Compatibility Layer, such as Wine.

The easiest way to use Wine is to install PlayOnLinux, a graphical frontend for wine, which can manage multiple virtual wine drives. Install it via the software center or sudo apt-get install playonlinux.

Now, from PlayOnLinux's menu, choose "Install a program that is not listed". Follow the instructions and give the installer the link to your Setup.exe, Setup.msi or whatever...

PS: Even though wine is a great piece of software, it cannot guarantee to run every Windows software on Linux. Some work perfectly, some partially and some not at all. In this case, use a VM.

share|improve this answer
    
I knw abut wine bt da problem is that it requires integration with other apps like browser so wine is a no go. –  user314107 Aug 30 at 16:10

VirtualBox, easy to use and you will get both worlds and even have them interconnected anyway you want. Plus it does not eat too much resources.

Wine may work, but not for all .exe installs, specially with the space limitation you have on you machine.

best of luck

share|improve this answer

Have you set your boot order to allow removable drives to be booted from first, then the HDD (Done through bios)

Also, when you start up the laptop, during the BIOS post screen (the black screen with all the white writting) hold down F8 until a screen with options comes up, in that list should be your HDD and the USB stick, choose the USB and you should be good to go

Try that and post back with results

share|improve this answer
    
I'm nt gonna dignify that answer by replying on that one. –  user314107 Aug 30 at 16:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.