Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to mount a NAS share to my Ubuntu 11.04. This is my first ever Linux machine, so everything is totaly new for me.

I can access the shares from my windows at: \\Packages (Packages is the share name on the NAS machine)

I can also mount (or at least I see the Packages icon on the desktop while going through Places) to the Packages share.

However, I want to mount Packages to my \home\administrator\Packages and here is the problem

Trying the following command:

sudo mount -t cifs // \home\administrator\Packages

throws error: mount error(13) permission denied.

I am putting in my password for the administrator when prompted. (no note - I have likewise to add the Ubuntu to the AD)

I than tried to add the -o username:administrator,password:password but got the same error.

I have isntalled smbfs lready, but don't think that this is the problem

sudo apt-get install smbfs

I will appreciate any help

I also tried

mount.cifs // /home/administrator/Packages -o dom=domain,user=administrator,pass=password

This gives

mount error(1): Operation not permitted
share|improve this question
up vote 2 down vote accepted


Because my NAS is a Netgear reaadynas 1100, it's running it's own CIFS unix system. The username and password I had to use are NOT of the domain, but actually of the NAS system.

So I changed to the NAS admin user + password and all is working !!

share|improve this answer

The last command you ran needs sudo

sudo mount.cifs // /home/administrator/Packages -o dom=domain,user=administrator,pass=password
share|improve this answer
thanks. tried it, same error. – Saariko Jul 4 '11 at 19:57

This is what I found when getting my Ubuntu Server 12.04.3 to mount my WDTVLiveHub share for my CouchPotato server. After giving up on Google and telling myself to RTFM I realised that I needed to include the sec=ntlm switch to avoid the Permission Denied error:

Add this to the /etc/fstab entry:

//host_name/WDTVLiveHub /media/WDTVLiveHub cifs username=Guest,password=Guest,sec=ntlm,nounix,uid=couchpotato,gid=couchpotato,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

Then mount in the usual way:

sudo mount -a
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.