Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 10.10 dual boot with XP. I planned to increase the size of swap partition. So I delete the swap partition. And I move the partition right so that swap partition can get 2 GB.

Then I shutdown the system without editing the appropriate UUID for swap in "/etc/fstab" file.

So when I start the computer It said "Continue to wait; Press S to skip; Press M to manual ... something" . But it does not respond for any thing (For pressing S or M).

Using live CD I resize and formatted the raw partition to linux-swap with GParted Partition Editor.The fstab file looked different in live CD So I tried recovery mode of Ubuntu.There I edited the fstab file with correct UUID for swapping.

After I reboot the System it never finishes booting

In the output of fdisk command the start sector(or block I don't know what it is) of swap partition is same as end value of consecutive partition.

So I made some space between swap partition and next partition(which is NTFS partion and not a system partition). I have updated the UUID in fstab file.

But it is again booting up continuously or infinitely

What might be the problem ?How to get rid of this ?


The output of the fdisk command

$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x022c022b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        6374    51199123+   7  HPFS/NTFS
/dev/sda2            6375       60800   437176814+   f  W95 Ext'd (LBA)
/dev/sda5            6375       21672   122881153+  83  Linux
/dev/sda6           21690       40659   152367104    7  HPFS/NTFS
/dev/sda7           40929       60800   159614976    7  HPFS/NTFS
/dev/sda8           40664       40925     2097152   82  Linux swap / Solaris

 Partition table entries are not in disk order

In Live CD

$ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/sda1: UUID="F8F81FD0F81F8C4E" TYPE="ntfs" 
/dev/sda5: UUID="b6768343-075c-44a5-8229-4070a80d2d49" TYPE="ext4" 
/dev/sda6: LABEL="entertainment" UUID="7630A95430A91C5D" TYPE="ntfs" 
/dev/sda7: LABEL="label1" UUID="9414A64F14A63460" TYPE="ntfs" 
/dev/sda8: UUID="1993033c-a261-4506-8520-2b5ff9fd9a60" TYPE="swap" 


I can start the Ubuntu in recovery mode.

I've mounted the filesystem located in the hard drive at mount point /mnt. The kern.log file(/mnt/var/log/kern.log) content is in pastebin.the link is kern.log

The fstab file(/mnt/etc/fstab) content is fstab

I pressed break key while splash screen is showing.It shows this line:

(process:311):GLib-WARNING ** :getpwuid_r(): failed due to unknown user id (0)

Then some messages repeated thrice.I again pressed break key the splash screen shown again.After few minutes When I pressed break key that messages repeated more.
I've noted and it is here.Some texts can be missing there.

fsck from Util-linux 2.17.2
/dev/sda5: clean, 191939/7684096 files, 5176534/30720288 block
* starting AppArmor profiles
Skipping profile in /etc/apparmor.d/disable:usr.bin.firefox
                                                                              [ok]
*setting sensors limits                                                       [ok]

*Not starting jetty-edit  /etc/default/jetty and change NO_START to be 0 (or     comment   it out)

Speech dispatcher disable: edit /etc/default/speech-dispatcher
*pulse Audio  (...... some thing ......)
Saned disable  (...... some thing ......)
* Enabling edit executable binary format bin fmt-super                        [ok]
*checking battery state ...                                                   [ok]
share|improve this question
    
What is the /etc/fstab on the install that won't boot up? (You could get this using a liveCD). What do you get if you run sudo blkid on the LiveCD? By booting infinitely, you mean it never finishes starting? –  Azendale Jul 4 '11 at 16:30
    
Yes it never finishes starting.booting process never end. –  Sankaran Jul 4 '11 at 16:54
    
@Sankaran: what is that "booting process never end"? Do you get past the GRUB bootloader? Do you see the Plymouth splash screen? If you boot in recovery mode, can you continue booting in normal mode? –  Lekensteyn Jul 6 '11 at 12:44
    
GRUB bootloader menu works well. The splash screen is shown. –  Sankaran Jul 6 '11 at 13:56
add comment

2 Answers 2

The Live CD has its own filesystem, /etc/fstab on the Live CD is not equal to the fstab file on your system. The Live CD is the right tool for this job.

First, mount your Ubuntu partition in a mount point:

sudo mount /dev/sda5 /mnt

Next, start editing the file:

sudo nano /mnt/etc/fstab

Navigate to the line containing the swap and press Ctrl + K to delete the line. Enter the following line in its place:

UUID=1993033c-a261-4506-8520-2b5ff9fd9a60 none            swap    sw              0       0

Save the changes by pressing Ctrl + X, followed by Y and Enter

share|improve this answer
    
I commented the line with #. But then also the starting up has not ended –  Sankaran Jul 5 '11 at 14:33
    
Could you post the contents of /mnt/etc/fstab and /mnt/var/log/kern.log on paste.ubuntu.com and add the link to your question? –  Lekensteyn Jul 5 '11 at 14:51
    
I pasted the contents and the link is in question –  Sankaran Jul 6 '11 at 12:10
add comment

I see that your new swap partition is known as /dev/sda8. You can use that instead of the UUID in your fstab file. In my opinion, it's easier, and problems are only possible if you add an additional internal hard drive.

From your live CD, you must mount your local filesystem before you can do anything productive.

sudo mount /dev/sda5 /mnt

The reason you couldn't mount it earlier is because you have to use sudo to mount a partition unless fstab explicitly says you don't. And in the live CD, it doesn't say so.

Now, your hard drive lives in /mnt. So, the correct fstab to edit lives in /mnt/etc/fstab.

Alternatively, you might prefer to set up a chroot. That means that you can have a shell where everything looks like it's running from your hard drive, not the live cd. To set this up, do the following after mounting /dev/sda5 on /mnt:

sudo mount --bind /sys /mnt/sys
sudo mount --bind /proc /mnt/proc
# The above two commands make kernel settings available to the chroot.
# They aren't always necessary, but they never hurt.

sudo chroot /mnt

At this point, you will be root on your internal hard drive. Thus, editing /etc/fstab will be the fstab on your hard drive, not the live CD. And all commands you run will be run from your hard drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.