Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am initiating file transfer using tcp on openfire server. But I am not able to open the port number 7777, from which I need to send files. I changed the security setting in the admin console panel of the aws. But still when I tried to send the files I am getting the error.

I tried to change the custom TCP rules, by opening only the 7777 port. But still I am not able to resolve it. Kindly help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Disable the firewall entirely - it serves no purpose. FTP needs to establish a connection back to your computer from the server on another random port to transfer files.

share|improve this answer
let me brief u about the application which I am developing I have installed open fire xmpp chat server in the server and I am trying to initiate the p2p, that means sending files from one mobile to another mobile via port 7777, which is a default port in openfire server, but I am not able to open that particular port. Thanks a lot for guiding me –  Jeevan Dongre Jul 5 '11 at 4:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.