Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a BIG probelm with VirtualBox, everytime i try to add or install the newest extension pack it gives an error, at first it asked me to add my user to the vboxuser group, which i already did, but still can't install the extensions pack.

How can i force Virtualbox to install it?

Error

it says, Failed to install extension pack. the path to the file, and the error itself.

Here i tried running it on the root terminal, but Virtualbox crashes.

 uri-MS-7267 uri # virtualbox
 Qt CRITICAL: Qt-subapplication(20282)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

 Qt WARNING: QPainter::begin: Paint device returned engine == 0, type: 3
 Qt WARNING: QPainter::setCompositionMode: Painter not active
 Qt WARNING: QPainter::end: Painter not active, aborted
 Qt WARNING: QPainter::begin: Paint device returned engine == 0, type: 3
 Qt WARNING: QPainter::setCompositionMode: Painter not active
 Qt WARNING: QPainter::end: Painter not active, aborted
 Segementation fault

When trying to install the Extpack from the terminal i get this:

 uri@uri-MS-7267 ~ $ sudo VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-4.0.10- 72436.vbox-extpack
 0%...
 Progress state: NS_ERROR_FAILURE
 VBoxManage: error: Failed to install "/home/uri/Oracle_VM_VirtualBox_Extension_Pack-  4.0.10-72436.vbox-extpack": The installer failed with exit code 1: VBoxExtPackHelperApp:   error: The owner is not root: '/usr/lib'

And i get nothing when using gksu.

 uri@uri-MS-7267 ~ $ gksu VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-4.0.10-72436.vbox-extpack
 uri@uri-MS-7267 ~ $ 
share|improve this question
add comment

3 Answers 3

up vote 6 down vote accepted

You can try to install the extension pack using the command line:

sudo VBoxManage extpack install <package file>

Some random things to check:

  • Virtualbox version and extension pack version must match.
  • Files on /usr/lib/virtualbox must be owned by root.
  • /usr/lib itself must be owned by root, too as Uri himself find.
share|improve this answer
    
I'm getting an error when installing that way, seems like it's still the same as above. –  Uri Herrera Jul 9 '11 at 21:59
    
i also tried with gksu and the command you suggested, i get no errors in return but, the extension pack doesn't show as installed. –  Uri Herrera Jul 9 '11 at 22:04
    
I added some blind shots, maybe one of them works. –  Javier Rivera Jul 11 '11 at 7:32
    
I've downloaded the previous version 4.0.8.7.1778 of both the Vbox deb and the ext pack, i've installed the deb and attempted to install the Extpack, and i still get the same error. :( –  Uri Herrera Jul 12 '11 at 3:24
1  
BTW, that was exactly what the error message was saying all this time... LOL. –  Javier Rivera Jul 12 '11 at 8:31
show 6 more comments

It seems to be saying you need to be root, so run it as root, and then install the pack.

share|improve this answer
    
It crashes when i run it with gksu or plain sudo, with QT warnings about me not having the oxygen theme (?). –  Uri Herrera Jul 3 '11 at 23:54
2  
@Uri you should probably report a bug O.o –  RolandiXor Jul 4 '11 at 3:23
    
Where do i report it? –  Uri Herrera Jul 9 '11 at 22:09
    
@Uri I'm not sure where they track their bugs. –  RolandiXor Jul 9 '11 at 23:36
1  
add comment

For me, this problem was cause by the wrong ownership of some folders and files in /usr.

root@mybox-01:~# ls /usr -la
total 152
drwxrwxr-x 11 501 501 4096 Nov 27 15:03 .
drwxr-xr-x 26 root root 4096 Dec 25 15:00 ..
drwxrwxr-x 2 501 501 57344 Dec 28 09:27 bin
drwxr-xr-x 2 root root 4096 Dec 25 19:45 games
drwxr-xr-x 35 root root 4096 Dec 25 19:45 include
drwxrwxr-x 167 501 501 36864 Dec 28 09:27 lib
drwxrwxr-x 3 501 501 4096 Nov 27 15:03 lib64
drwxrwsr-x 10 root staff 4096 Dec 24 18:34 local
drwxr-xr-x 2 root root 12288 Dec 28 09:27 sbin
drwxrwxr-x 278 501 501 12288 Dec 28 09:27 share
drwxr-xr-x 5 root root 4096 Dec 28 09:27 src

The fix was to do chown root.root -R /usr

Then run the command VBoxManage extpack install <package> file again..

I'm not sure how this was caused but I hope the "fix" doesn't break anything else on my system..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.