Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop ThinkPad Edge E430, with Xubuntu 12.04.4 LTS installed on it. I'm using wicd to manage my networks. My wired network works just fine, but I can't detect any wireless network ("no wireless networks found") although I've checked that there were several wireless networks available nearby (I have a dualboot with windows).

  • Wicd network manager

I've reinstalled the wicd, just for case:

sudo apt-get install --reinstall wicd

I've tried this great AskUbuntu troubleshooting answer [My WiFi adapter is not working at all, how to troubleshoot?]:

I've installed all updates. I've checked my network with lshw:

sudo lshw -C network

*-network               
   description:   Wireless interface
   product:       BCM4313 802.11bgn Wireless Network Adapter
   vendor:        Broadcom Corporation
   physical id:   0
   bus info:      pci@0000:03:00.0
   logical name:  eth2
   version:       01
   serial:        08:3e:8e:a2:91:9f
   width:         64 bits
   clock:         33MHz
   capabilities:  pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264)
                  latency=0 multicast=yes wireless=IEEE 802.11abg
   resources:     irq:17 memory:f2d00000-f2d03fff

I ran rfkill for possible software and hardware switches:

rfkill list

0: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
2: brcmwl-0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

I figured out that I have "hardware requiring special care" as mentioned at the bottom of the post so I followed attached link [Installing Broadcom Wireless Drivers].

My wireless card is:

lspci -nn -d 14e4:

Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)

So the table suggested me to install bcmwl since my kernel version is 3.2.0-67-generic.

sudo apt-get install bcmwl-kernel-source

bcmwl-kernel-source is already the newest version.

I've rebooted my PC.

And now I'm stuck. Can you help me solve the wireless network issue or at least locate the problem? Is it driver issue? Is it wicd issue? Is it bfu user issue?

share|improve this question
    
Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…; –  Wild Man Aug 27 at 13:49
    
I was looking in some older posts for the same issue: is the wireless interface listed in the wicd preferences? answers.launchpad.net/ubuntu/+question/220088 –  Charles Green Aug 27 at 14:42
    
Include the output of iwlist wlan0 scan (replacing wlan0 with whatever your device is called). –  Braiam Aug 27 at 14:48

3 Answers 3

Open a terminal and insert these commands:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source

reboot and see if it works

share|improve this answer
    
I tried. Linux headers were already the newest version. I rebooted the PC and no success. Can't detect any wireless network although I'm in range of several of them. Wired network still works fine. –  Jeyekomon Aug 27 at 10:05
    
But you did reinstall the bcmwl-kerle-source? –  Rat2000 Aug 27 at 10:09
    
Of course I did all the commands you provided. –  Jeyekomon Aug 27 at 10:19
    
I edited my response, please try the new commands –  Rat2000 Aug 27 at 10:41
    
Sorry for delay, I've been reinstalling wicd, just for case, checking for non-wicd way of displaying wireless etc. I ran both commands, rebooted but still no wireless networks were found. :-( Something must be terribly wrong in my PC. –  Jeyekomon Aug 27 at 11:08
up vote 0 down vote accepted

Problem solved.
Solution: I gave up and used the last option - reinstalled the OS from scratch. I've installed the latest Trusty Tahr LTS and everything works fine. I was using the OS for just a couple of weeks so the loss of time and effort isn't that huge.

share|improve this answer
    
But to be honest, from the first view Trusty Tahr looks and works way better than Precise Pangolin. They really did some work there. –  Jeyekomon Aug 27 at 15:02

Just to be sure, try to uninstall Network Manager with sudo apt-get purge nm-applet

share|improve this answer
    
Why in the world would he want to do this? –  Seth Aug 27 at 14:13
    
@Seth: Well I actually did it after I installed the wicd. –  Jeyekomon Aug 27 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.