Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've added a new PPTP VPN connection under Network Manager -> VPN Connections -> Configure VPN. Now the connection is listed under "VPN Connections", but it's grayed out.

How can I debug this?

Whatever I've tried doesn't seem to help: checked the logs--no clues, toggled 'Available to all users', toggled 'Connect automatically', logged in and out a few times, etc.

It would be nice if Network Manager didn't gray the item out when it detects some configuration problems, but let me click the item and show some error message after that.

  • network-manager-pptp and network-manager-pptp-gnome are both installed.

UPD: I cannot reproduce the problem right now: it has cured itself it seems. Still I'd be grateful for debugging ideas if it happens again. I'd rather avoid running gdb against network-manager, which seems to be the ultimate way to solve this.

share|improve this question
    
Please add the Ubuntu version to the tags. You shouldn't be able to save a bad configuration, so I don't think that's the problem. Do you have the packages network-manager-vpnc and network-manager-vpnc-gnome installed? You can run apt-cache policy PACKAGENAME in a terminal to check. –  htorque Jul 3 '11 at 17:38
    
Forgot to add that this was PPTP, not VPNC one. Added version tag. –  alex Jul 3 '11 at 17:52
    
Just checked: network-manager-pptp and network-manager-pptp-gnome are both installed. –  alex Jul 3 '11 at 18:37

3 Answers 3

I had the same issue on Ubuntu 12.10 and fixed it by restarting nm-applet like this...

killall nm-applet
nm-applet --sm-disable &
share|improve this answer

This is likely to be due to Gnome Keyring being locked, preventing you to access the connection.

This is apparently a known issue when using automatic login: The keyring doesn't get unlocked and it prevents you to do some things such as connecting to a VPN. As soon as the keyring gets unlocked (For example by trying to edit the connection settings) the VPN connection is not disabled anymore.

There are various options to unlock the keyring automatically when login, but the simplest I found was to just use a blank password for my keyring. Not very secure, but eh...

To change your keyring password, start the "Password and Keys" app.

share|improve this answer

Try installing network-manager-openvpn and network-manager-vpnc and linux-pptp.

sudo apt-get install network-manager-vpnc network-manager-openvpn linux-pptp

I know it's PPTP but it can't hurt to try this.

If that doesn't work, try this:

  • Backup /etc/network/interfaces to /etc/network/interfaces.original.
  • Delete all lines from /etc/network/interfaces not including the string "lo" (leaving two lines, probably the first two, beginning auto and iface).
  • Reboot.

Hope this works for ya!

From http://ubuntuforums.org/showthread.php?t=974882

share|improve this answer
    
No, this is not the problem I'm facing. I can add a VPN connection, but cannot activate it, because the VPN connection item I've added is grayed out (disabled) in the NetworkManager menu. –  alex Jul 18 '11 at 14:35
    
just try it and then see if it works especially the linux-pptp –  PitaJ Jul 18 '11 at 21:55
    
I have all of the above already installed (and it's pptp-linux, not linux-pptp.) Now the problem has cured itself apparently, as I'm no longer able to reproduce it: the added connection isn't grayed out anymore. :-/ –  alex Jul 19 '11 at 4:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.