Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My HDD is reaching a very high temperature, aprox. 50°, while using Ubuntu. On Windows it only gets as high as 40° and it causes the touchpad to get hot.

What can I do to determine what is causing this behaviour and how can I cool off my drive?

My notebook is a Toshiba A300-2D4 with an ATI Mobility Radeon HD 3470 graphics card.

share|improve this question

3 Answers 3

Did you try to open the powermanager and tick the box to allow the hdd to spin down whenever it is possible? Use powertop (you can find it in synaptics paketmanager) and increase dirty writeback as proposed by powertop. Pls report back if this reduced the temp.

share|improve this answer
    
Yes i tried and tick box to allow the hdd to spin down whenever it is possible. but positive results did not. –  user21042 Jul 3 '11 at 18:59
    
i still try powertop –  user21042 Jul 3 '11 at 19:16
    
In former time some issues were reported that there is a difference between being on ac or battery. Same problem if you are on battery? –  dago Jul 3 '11 at 20:55
    
i am not use battery, my battery is not work. only ac –  user21042 Jul 4 '11 at 15:45

I've had a similar problem with my hdd (Scorpio blue WD2500BEVT), but I've solved by setting the sata link to min_power instead of the default max_performance: as root, check the files on: /sys/class/scsi_host/host0/link_power_management_policy, and /sys/class/scsi_host/host1/link_power_management_policy, etc.

if you get max_performance, then change it:

echo min_power > /sys/class/scsi_host/host0/link_power_management_policy

the same on the other files. Notice that this will get back to the default when you restart, or when you came back from a suspended mode, so you'll have to apply this every time. I've also set hdparm to -B128. If any of this does not work try to monitor your hard drive and check how many times it is been accessed, maybe modifying your fstab file, google it, on how to improve the hard drive. hope this help you, it got me really upset.

share|improve this answer

try using hdparm, if supported

hdparm --help

you can try hdparm -S 9 (for random example)

share|improve this answer
    
i try, omergex@omergex-Satellite-A300:~$ sudo hdparm -S9 /dev/sda /dev/sda: setting standby to 9 (45 seconds) but still high temp :( How can I benefit from this program. and i am sorry my poor english :( –  user21042 Jul 3 '11 at 18:54
    
omergex@omergex-Satellite-A300:~$ sudo hdparm -M160 /dev/sda /dev/sda: setting acoustic management to 160 HDIO_DRIVE_CMD:ACOUSTIC failed: Input/output error acoustic = not supported –  user21042 Jul 3 '11 at 19:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.