Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have a problem during deploying my first juju environment "maas". The host is commissioned by MAAS but during the juju deployment there is this error:

Setting up libtcmalloc-minimal4 (2.1-2ubuntu1) ...
Setting up libgoogle-perftools4 (2.1-2ubuntu1) ...
Setting up libsnappy1 (1.1.0-1ubuntu1) ...
Setting up juju-mongodb (2.4.9-0ubuntu3) ...
Processing triggers for libc-bin (2.19-0ubuntu6.1) ...
curl: (22) The requested URL returned error: 503 Service Unavailable tools from
downloaded: HTTP 503; time 74.994s; size 0 bytes; speed 0.000 bytes/s
2014-08-26 06:00:43 ERROR juju.provider.common bootstrap.go:123 bootstrap
failed: rc: 1
Stopping instance...
2014-08-26 06:00:43 INFO juju.cmd cmd.go:113 Bootstrap failed, destroying environment
2014-08-26 06:00:43 INFO juju.provider.common destroy.go:14 destroying environment "maas"
2014-08-26 06:00:44 ERROR juju.cmd supercommand.go:300 rc: 1

i use Ubuntu 14.04 in a KVM environment.

my environments.yaml looks like:

    type: maas
    maas-server: ''
    maas-oauth: 'ZJ9GLGqSVSWdZ6eXET:AjCdJRwgS26jsBwHp8:gpwhCLf6P2AJCh3mcGL2vRqhbSvkwRGB'
    admin-secret: 'MY-PASSWORD'
    default-series: trusty
    no-proxy: localhost,
    bootstrap-timeout: 1800

does someone know this problem?


share|improve this question

Your no-proxy setting has incorrect format. It should be a comma-delimited list of IP addresses, not a CIDR range. Take a look at this related question:

I'd recommend you set no-proxy:, instead and try again. If it does not work, please update the question and maybe file a bug against juju-core:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.