Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Windows, when you click on the address bar, it automatically highlights all of the web address so you can enter another one without having to drag across everything. I've noticed that it doesn't do that in Chrome or Firefox (I don't know about other browsers). This is very annoying, especially when the site has a long address that goes past the end of the address bar. How can I fix this?

share|improve this question
2  
You can change the behavior to your liking in 'about:config' as suggested below, but it doesn't need fixing. The default setting it correct. –  mikewhatever Jul 3 '11 at 8:46
3  
The reason it normally requires a double click to highlight the text is interface consistency. Where else is text highlighted on a single click? –  scottl Jul 27 '11 at 0:55
add comment

5 Answers

up vote 12 down vote accepted

In firefox, you can change this configuration setting through the "about:config" command.

In the address bar, type in and go to:

about:config

Click on the "I'll be careful, I promise" radio button. And input in the following query into the filter:

browser.urlbar.clickSelectsAll

Double click on the entry to toogle its value between true and false. Select "False" if you want to place the cursor at the insertion point, and select "True" if you want to highlight the entire address bar on a single mouse click.

Here is a link to an article that gives some more useful "about:config" hacks:

28 Coolest Firefox About:Config Tricks

share|improve this answer
add comment

Ctrl-L selects the location bar. After selecting you're going to type anyway so I don't find the process objectionable.

share|improve this answer
2  
Also, F6 will highlight the bar in Chrome, and F6 then Tab will also do that in Firefox. –  loudandclear Jul 3 '11 at 7:54
add comment

Double click on on the address bar, and it will select the address.

share|improve this answer
    
by default. Firefox's about:config setting is: browser.urlbar.doubleClickSelectsAll ; true so the third cilck is not needed, but that extra click doesn't upset the full selection... I don't know about Chrome (because I don't use it :)... –  Peter.O Jul 3 '11 at 6:38
    
@fred on my system (at some times) double click didn't work :P - it does now though so it must have been a problem with my profile. Thanks! –  RolandiXor Jul 3 '11 at 18:47
add comment

also Alt+d highlight the address

share|improve this answer
add comment

I believe the reason that clicking doesn't highlight the entire address is to facilitate partial selection of the URL.

For example on this page you may wish to select the question ID, which you can do with a simple double-click.

Or you may wish to delete everything after the domain, to return to the home page (assuming there is no "home" link). Or copy just the domain for whatever reason.

share|improve this answer
1  
Good comment, but it's not an answer; otherwise I'd vote this up. –  Chan-Ho Suh Apr 4 '12 at 6:11
    
@Chan-HoSuh How is it not an answer? The question is why don't browsers auto-highlight; my answer provides a reason. –  DisgruntledGoat Apr 4 '12 at 10:42
1  
If you read the entire post, it's clear the person wants a solution to their problem, not a reason as to why the UI is setup differently than they expect. –  Chan-Ho Suh Apr 5 '12 at 3:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.