Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been successfully running Ubuntu 12.04 (dual boot with Windows 7) on an ACER Aspire 7750 laptop for several years. Last week I selected upgrade to 14.04 from the Update tool. The 14.04 install (linux kernel VMLINUZ-3.13.0-34-generic) produces 22 second soft lockups from Xorg which results in the screen, mouse and keyboard freezing for about 20 seconds like clockwork.

I did a backup of the Ubuntu files, removed all Ubuntu installs, repartitioned from Windows, reinstalled 12.04, installed all updates and then upgraded to 14.04 again. Same result.

Selecting the VMLINUZ-3.2.0-67-generic kernel from the grub menu the system seems to function properly. If I boot with VMLINUZ-3.13.0-34-generic (the new install), the screen (mouse and keyboard) freeze (~20 seconds active and ~20 seconds frozen). On shutdown from this condition, the system reports the soft lockup on one of the CPUs and indicates that it is associated with Xorg (tainted).

Pardon my ignorance, but I have attempted to find a troubleshooting approach or a fix on the Ubuntu sites, Linux sites and on the internet in general with no luck.

When the problem is existing, it is difficult to perform any file review since the functional windows are very short. I am able to get to a functional desktop with either the previous kernel (3.2.0-67) or by booting in recovery mode and failsafe graphics.

Any help would be appreciated.

Update - Aug 25 2014 - I finally removed the upgraded Ubuntu system and decided to start with a clean install of version 14.04 instead of upgrading from 12.04. The first DVD startup disk with desktop 14.04 showed the same soft lockup performance. After some review, I found that the DVD was based on the 32 bit version of the desktop software. When I downloaded the 64 bit desktop version of 14.04 and started with a clean install of the 64 bit Ubuntu, all worked well.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.