Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Some times I have to deal with XPS files (XPS is a Microsoft's rival to Adobe's PDF format, technically a zipped XAML (XML)).

Can I view them in Ubuntu? Or, maybe, I could even produce them?

share|improve this question

Okular, the KDE pdf viewer, supports XPS. The package name is okular I'm not aware of any GNOME/GTK+ viewers that support XPS, though according to this evince bug in upstream GNOME support has been added. It's not working for me in Maverick....

share|improve this answer
Okular did the job but Arabic characters are garbled. – Tarik May 13 '14 at 7:52
Now the bug you are reporting is resolved fixed! :-) – luca76 Apr 14 at 13:27

Evince has XPS support now. Check:

share|improve this answer
Google Docs also supports this format as of February 2011:… – Tom Brossman Dec 23 '11 at 7:13
Did you know, MS SampleXpsDocuments archive is a Win32 executable and weights 159 MiB? :-) I am going to check the answer (to know it Evince XPS support is really usable) as soon as I find a sane XPS file to try... – Ivan Dec 27 '11 at 5:24
Does Evince really support XPS? The link below the list doesn't say so. And it doesn't work here. – Jakob Mar 14 '12 at 9:03
@Jakob evince upstream supports it, but the package in ubuntu does not currenty use it. It requires a package libgxps which was just included in 12.04 and to be enabled in evince package, which is underway - there is no guarantee though because we're a bit late. See… and "XPS not supported" – medigeek Mar 26 '12 at 16:51
Evince showed my XPS file as a blank page. – Tarik May 13 '14 at 7:55

To me, the most suitable solution on my 12.04 computer was to convert the XPS file to PDF on the command line through

xpstopdf file.xps

and viewing the newly created file.pdf using whatever PDF viewer (acroread in my case).

This required installing the package libgxps-utils.

(Evince did not open the XPS file that I ran into, at least out of the box, but complained "File type Zip archive (application/zip) is not supported".)

share|improve this answer
xpstopdf crashed when invoked. – Tarik May 13 '14 at 7:53
Same here - error message was "Error creating XPS file: Invalid XPS File: fixedrepresentation not found" – Steve Kroon Jul 29 '14 at 8:08
Didn't work for me: (xpstopdf:87500): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory. This indicates a bug in someone's code. You must ensure an error is NULL before it's set. – etech Nov 12 '15 at 0:12
Worked for me. On Ubuntu 14.0.2, great! – spikeyang Dec 17 '15 at 7:08
@SteveKroon: I get that with OXPS files. Normal XPS seems to work... – Gert van den Berg Mar 7 at 12:46

If you want to create XPS files, your best bet may be to try to build the GhostXPS component of GhostPDL (part of the Ghostscript suite); I don't know if this has ever been pacakged for Ubuntu, and I don't have first-hand experience with it.

Inkscape can both read and write .xaml files. I suppose it could even be used to convert, e.g., .pdf or .svg to .xaml. I don't know, however, whether or not it can handle .xps files directly (perhaps not).

share|improve this answer
Inkskape failed to read my xps file – Tarik May 13 '14 at 7:13

protected by Community Oct 14 '13 at 23:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.