Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a bug filed as my USB3 thumb drive in Maverick and Natty only gets detected as a USB2 device (please find some details below).

Launchpad bug record

  • Has anyone an idea how to troubleshoot that further or get it fixed?
  • Can anybody confirm USB3 devices working on an ASUS M4A88TD-V EVO/USB3 motherboard (with a NEC uPD720200 USB 3.0 onboard chip) on any of both USB3 ports?


What I've also done to troubleshoot/fix without success is:

  • checked all USB ports to be sure not to use the wrong one
  • blacklisted the usb2 kernel module (ehci_hcd) to enforce loading of usb3 kernel module (xhci_hcd) while connecting the thumb drive
  • checked different upstream kernel instead of the default Ubuntu kernel
  • checked different Ubuntu kernel (also from kernal-ppa)
share|improve this question

closed as off topic by Marco Ceppi Feb 1 '12 at 23:55

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you sure, you plugged it into an USB3-Port on your computer? Some (cheaper) pcs have both usb2 and usb3 ports. –  con-f-use Jul 2 '11 at 9:31

Browse other questions tagged or ask your own question.