Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to install and run some 32-bit software on my 64-bit Ubuntu 11.04 machine, so it was suggested I run sudo apt-get install ia32-libs. I got the following:

$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  lib32asound2 lib32bz2-1.0 lib32gcc1 lib32ncurses5 lib32ncursesw5
  lib32stdc++6 lib32v4l-0 lib32z1 libc6-i386
Suggested packages:
  lib32asound2-plugins
The following NEW packages will be installed:
  ia32-libs lib32asound2 lib32bz2-1.0 lib32gcc1 lib32ncurses5 lib32ncursesw5
  lib32stdc++6 lib32v4l-0 lib32z1 libc6-i386
0 upgraded, 10 newly installed, 0 to remove and 21 not upgraded.
Need to get 60.3 MB/65.2 MB of archives.
After this operation, 212 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Err http://us.archive.ubuntu.com/ubuntu/ natty/universe ia32-libs amd64 20090808ubuntu13
  Connection failed [IP: 172.22.140.250 8080]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu13_amd64.deb  Connection failed [IP: 172.22.140.250 8080]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So I ran sudo apt-get update and then sudo apt-get -m install ia32-libs, which installed all the packages except ia32-libs. Now I'm getting:

$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  ia32-libs
0 upgraded, 1 newly installed, 0 to remove and 21 not upgraded.
8 not fully installed or removed.
Need to get 60.3 MB of archives.
After this operation, 199 MB of additional disk space will be used.
Err http://us.archive.ubuntu.com/ubuntu/ natty/universe ia32-libs amd64 20090808ubuntu13
  Connection failed [IP: 172.22.140.250 8080]
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu13_amd64.deb  Connection failed [IP: 172.22.140.250 8080]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

How do I troubleshoot this problem?

This machine is behind a firewall, so that could be the problem. But I think it's unlikely since all the other packages were downloaded without a problem.

Update: Now when I run sudo apt-get install ia32-libs I get:

$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0 lib32asound2

E: Package 'ia32-libs' has no installation candidate

I tried sudo apt-get update, but get the same results when I tried sudo apt-get install ia32-libs again afterward.

Did the ia32-libs package really disappear since I last tried it? Or is this the result of an environmental issue caused by what I did to try to work around the problems above?

share|improve this question

1 Answer 1

That looks like 172.22.140.250 is your http proxy (it's in the private 172.16.0.0/12 address space) but for some reasons you can't connect to it.

Maybe your configuration or the proxy's configuration have changed since you downloaded the other packages or the proxy is not working any more.

share|improve this answer
    
Strange that the proxy would only block connections for some of the updates. (I guess that makes it more likely that it's the proxy's configuration that is causing the issue, not my configuration for using the proxy.) –  Daryl Spitzer Jul 5 '11 at 18:11
    
Then packages lib32z1, lib32ncurses5, lib32bz2-1.0 and lib32asound2 are in main while ia32-libs is in universe - maybe there's a pattern here. Can you access us.archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/… with wget and with your browser? Is your proxy expected to block some URLs? Can you install any package after do run sudo apt-get clean? –  Florian Diesch Jul 5 '11 at 18:45
    
Yes, I can access us.archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/… with wget and Firefox on that machine. I don't know if our proxy is expected to block some URLs. –  Daryl Spitzer Jul 5 '11 at 19:43
    
I did sudo apt-get clean and then sudo apt-get install lib32z1 ran without error. –  Daryl Spitzer Jul 5 '11 at 19:48
    
Do you still get the error when trying to install ia32-libs? If so: What does apt-cache policy lib32z1 print? –  Florian Diesch Jul 5 '11 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.