Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would to define Windows-like shortcuts using the Super ("Windows") key. I'm running Xubuntu 11.04 (Natty).

Using Settings->Settings Manager->Windows Manager->Keyboard I assigned Super+D to "Show desktop".

Then, using Settings->Settings Manager->Keyboard->Applications Shortcut I assigned Super+E to thunar. So far, everything works perfectly.

But, at least, I'd like the Super key when pressed alone to open the Applications Menu but, being Super a modifier key I wasn't able to assign it alone to a shortcut. For reference this problem is also described here.

Based on this forum post I used to xmodmap to make it behave like a normal key - ie. not a modifier key. And guess what, it works. Sorta.

Super alone works perfectly. Super+E still opens thunar but also opens the Applications Menu. Super+D no longers works at all.

Of course, I can just remove my .Xmodmap file and assign a Super+A or similar to Applications Menu. But if there's a way to get just Super working it would be great.

Can someone shed some light on this issue?

share|improve this question
1  
@DoR Out of curiosity (and I'm new here): how do you add this "key" effect to words? – Vitor Py Jul 2 '11 at 0:24
2  
<kbd>text</kbd>. You can see how any formatting on here is done by clicking edit and looking at the source. – Alvin Row Jul 2 '11 at 0:31
    
Have you tried adding both shortcuts to the same place? Try setting Super + D in Keyboard shortcuts, maybe? – charlie-tca Jul 7 '11 at 18:28
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it open. Regards – Bruno Pereira Feb 25 '12 at 1:11
    
Please reopen this Question. Reasons : this is still an existing problem in Xubuntu. How Set Super key for Application and super+D for Desktop is nowhere mentioned. – Severus Tux Apr 27 at 2:20

I had the same issue and I finally resolved it. Since there is no way to solve this with Xfce alone, one needs the small tool ksuperkey. It was originally developed for KDE, but it works fine on other desktops. You basically install ksuperkey or compile it yourself, and bind your menu to "alt+f1". Once you run ksuperkey, the superkey will behave as one would expect. I highly recommend to put this tool into some form of autostart, so that ksuperkey gets started on startup. Set it and forget it!

share|improve this answer

Restore back what you did. In natty super key is already used for menu.

share|improve this answer
1  
Removing the xmodmap modification and the Super_L shortcut to the Applications Menu doesn't work. Pressing Super alone does nothing. – Vitor Py Jul 2 '11 at 16:57
2  
In Ubuntu Natty super key is used for the menu. The same is not true for other distributions. Xubuntu does not use Unity, and does not use the shortcuts assigned by Unity. – charlie-tca Jul 7 '11 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.