Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows 7 / Ubuntu 12.04 dual-boot which I have been using for some time without issue. While booted into Windows, my computer froze (for reasons unknown, just completely locked up 100%), so I did the only thing I could, I turned it off. Since then, My computer does not boot correctly. I no longer see a bios init screen, I no longer see a GRUB menu, I just get a blank screen for about 15 seconds or so, and then the Ubuntu login scree pops up.

I have tried using update-grub to rebuild my grub config to no effect. I am completely at a loss and urgently need a fix for this. Please help D:

share|improve this question
1  
Turning off a working Computer almost always corrupts file system. At the minimum you need to use your Windows repair CD or flash drive to run chkdsk on all NTFS partitions and/or from Ubuntu live installer same version as your install run e2fsck. But if BIOS cannot see drive, you may not be able to do anything and drive is damaged. –  oldfred Aug 16 at 4:02
    
I shut off my computer for about 30 minutes while researching possibilities, went to turn it on to test something, and suddenly it was working normally again... I still have no idea what was wrong with it... –  kbjr Aug 16 at 4:11

2 Answers 2

Please post your default grub file. Post what you see when you type

sudo gedit /etc/default/grub

if grub_timeout is equal to 0, change it to 10.

share|improve this answer
    
And then run 'update-grub' –  Jatin Kaushal Aug 16 at 14:49
    
Yes, I'm aware of that; I already checked the timeout value and tried update-grub, as I mentioned in the original post with no change. –  kbjr Aug 16 at 23:34

I turned off my computer for about 30 minutes or so while I was researching possibilities, and when I turned it back on to try something new it was suddenly working fine again. I still have no idea what was wrong with it ... but at least it is working now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.