Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was able to change the resolution to 1920x1080 by changing parameters in /etc/default/grub. But if I set the resolution to 2160x1440 (the resolution of Surface Pro 3), it does not accept this setting. I am reading everywhere that 1920x1080 is max resolution, but I don't understand why. There must be a way how to increase max resolution. Can anyone help?

share|improve this question
I have the same problem with you, I google several hours but find no answer. Finally, I got a solution and it works well for me. You can install xrdp on the ubuntu(guest OS in Hyper V), and then connect ubuntu by mstsc. Now it works in 2160x1440. – Zhou Sep 12 '14 at 15:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.